5

PC1 & PC2 are both running Windows 7 Professional. 64-bit & 32-bit respectively.

PC1 contains a secondary internal HDD, as D:\

PC1 also has an external HDD as E:\

D & E are shared on PC1.

On PC2, I can map to \\PC1\E, using the credentials of PC1's admin user.

On PC2, if I attempt to map to \\PC1\D, using the credentials of PC1's admin user, I receive an error:

The network folder specified is currently mapped using a different user name and password.

To connect using a different user name and password, first disconnect any existing mappings to this network share.

If I open cmd and run net use, I see that \\PC1\E is mapped, but \\PC1\D is not mentioned.

Why can't I map to \\PC1\D on PC2? Thanks.

  • Are you able to connect to D:\ from a browser without mapping it? Do you have the same issue if you remove E:\ before? – Máté Juhász May 16 '15 at 6:49
2
+100

On Windows 7, once you've authenticated against a server, you don't have to reauth for other mappings.

In fact, if you map a share to a drive letter, and then try to map a different share on the same server to a different drive letter, and then enter on the Map Network Drive dialog the same username and password used on the first drive mapping, you get this confusing error message:

The network folder specified is currently mapped using a different user name and password.

Despite the network folder not being mapped at all, and the username and password used not being different.

This baffled me for a while until I realized that once you have mapped to "server1" using those credentials, you can map to different shares on the same server without re-specifying the credentials.

(source)

  • That link is accessible only to people with a Microsoft account. Please include the essential information in your answer. Thanks. – fixer1234 May 16 '15 at 6:33
  • I'm not signed in and it works in an incognito window. Everyone has access. – Alex Atkinson May 16 '15 at 6:34
  • Didn't work for me. Message says the site can't sign me in and just presents a sign-in page. External links can break or be down, in which case any information there is unavailable. In general, it better to use links only for attribution and further reading (especially if you are pursuing a bounty :-} ). – fixer1234 May 16 '15 at 6:44
  • @fixer1234 : I take Alex Atkinson's side on this. I don't use a MS acct on this computer, and I've no problems. MS's web site must be realizing something about your MS account, or the cookies in your web browser, or something, but most people (who aren't signed into any MS account) will have no problem accessing the page. (Your easiest option might be to just sign in.) – TOOGAM May 16 '15 at 6:47
  • 4
    @TOOGAM: The problem might be temporary or solvable, but I, and anyone else with a similar problem, can't access the information, which is why external links shouldn't be used for information essential to the answer. There is no reason a user should have to solve a web site problem to get the information the answer is supposed to provide. – fixer1234 May 16 '15 at 7:01
1

Go to PC1 and inside D: > Properties > Security > Advanced > Owner - is the same as on C:, if not, change that.

If this does not help,
open cmd
Enter net use * /delete in the dos box

than try again

1

I've seen this before. Here's what you need to do:

Instead of mapping to \\PC1\D and \\PC1\E respectively, try mapping to the admin shares

The admin shares that you will want to connect to are \\PC1\D$ and \\PC1\E$. To do this, open Command Prompt, and type this (you could also save this to a .bat file on your desktop, such as connect.bat to execute at any time):

net use H: \\PC1\D$ /user:\\PC1\foobar 123456
net use I: \\PC1\E$ /user:\\PC1\foobar 123456

Simply replace H: and I: with drive letters you want, change foobar to the admin user, and change 123456 to the password of said admin user

1

You might have a spurious network share to \\PC1\D. This is easy to verify by entering into a command-line the command :

net use

If you see any other share in addition to \\PC1\E, which might even be that of the administrative share of D, just enter the command :

NET USE /DELETE \\PC1\share-name

You should now be able to connect to \\PC1\D without problem.

If this doesn't work, try to connect to <PC1 IP address>/D, entering the credentials as
<PC1 IP address>/user-name.

0

I suggest you try to list the folders being shared and mapping each one of them, but at the same time, instead of giving the full path using the "map network drive" option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.