9

I often use RealVNC Viewer to connect to remote VNC desktops served by RealVNC Server, Tight VNC Server, X11VNC... etc.

When connected, all pressed hotkeys are passed to (captured by) the remote desktop, and that is OK for me, but I then need use to the mouse to click on my local desktop if I want to interact with local programs... and keys are always faster than the mouse.

Is there any hotkey to escape from the remote desktop and send focus to the local desktop?

5 Answers 5

7

I don't know about any hotkey for escaping nor way to define it at RealVNC Viewer. I would really love to know.

Meanwhile, I use two workarounds for this:

  • Pressing some hotkey that is defined (say Ctrl+Shift+E for Windows Explorer) for a local program (on the computer running VNC Client), as long as they are prioritized by RealVNC Viewer. This automatically send focus to local desktop. Problem: such hotkey will not work on the remote machine (you can not define Ctrl+Shift+E for Windows Explorer on the computer running VNC Server) .
  • Pressing this key sequence: F8, then n (to minimize; maybe any other on your Windows). Problem: this minimizes the window that shows the remote desktop, and some times you don't want this.

The first one is preferred for me, since a sequence is always slower than a direct hotkey.

7
  • 1
    Managed to find this comment from within a remove VNC session that I could not escape (couldn't reboot host), F8 worked wonderfully
    – MSpreij
    Oct 2, 2018 at 15:40
  • Could you explain the first possibility with an example please? I did not understand exactly what you mean Aug 3, 2019 at 19:05
  • Added more details, @MohammedNoureldin . I hope it will help. Aug 5, 2019 at 10:53
  • Thank you for your replay. Could you please also add how did you add this shortcut to Windows Explorer? And what did you mean by prioritized by RealVNC? Aug 5, 2019 at 11:31
  • The shortcut key for a program can be configured at Properties--> General tab inside its launcher direct link, @MohammedNoureldin . Aug 8, 2019 at 11:23
3

I fixed this by disabling the "send special characters" setting in Real VNC's advanced settings. I use OSX, so now I can command+tab to switch to a different app.

2
  • 1
    The downside: you loose remote alt+tab feature. Jun 28, 2019 at 10:14
  • 1
    I didn't. Alt+tab is not a special sequence on osx so that passes through to the remote system just fine. You are probably right if your local machine is windows though.
    – rbrc
    Jun 29, 2019 at 18:26
2

I solved this under Windows 10 using AutoHotkey, which understandably is not suitable for all users/use cases. The code can be compiled into a .exe file.

The code listens for control-F1 to be pressed, and when triggered, sends the F8 keystroke top open the menu, followed by n (to minimize). This could be written to only work when VNC Viewer is the active window, but this meets my needs.

;; Escape VNC
^f1::   ; press control-F1 to escape
    send {f8}
    send n
    return

https://www.autohotkey.com/

1
  • Not a bad idea, since a autohotkey resident process is a small one. But I would say that only working on the VNC active window is mandatory. Nov 30, 2020 at 15:38
0

I came here looking for the same solution and what worked for me was:

  1. Left-click on VNC logo at left side of titlebar or hit F8 if mouse is stuck in VNC session.
  2. Uncheck "Relative Pointer Motion"

Now I can freely move my mouse from local to remote contexts just by moving the mouse to the session I want.

2
  • Well, I would thank any example on how could this method be used to do anything just by using keys, not mouse. Say you are typing (forget you have a mouse plugged, please, the question is about "using keys") inside notepad on a remote RealVNC Windows XP screen, and you want to end opening Windows Explorer on local computer (please: without a mouse) that, as it is known, can be achieved by pressing WinKey+E. What would be the sequence of keys pressed in between? May 18, 2018 at 1:29
  • Thank you 👍 this was exactly what I was looking for. Worked like a charm! May 21, 2020 at 16:41
-1

F8 - uncheck Full Screen

Works even with Send special characters turned on.

2
  • Welcome to Stack Exchange forums, Rakly3. Could you please add some more details? Maybe the exact steps you suggest to obtain the results requested in the original question (escape from the remote desktop screen) would help. I would test your disabling Full Screen method, but my remote VNC screens are always in window mode, not full screen, so I have nothing to disable. Feb 16, 2020 at 14:31
  • I don't have it in front of me. I'll double check when I can (and remember) But iirc while your mouse pointer is captured by your remote desktop, pressing F8 should escape you back to your actuall desktop. I found some more information about the F8 function. The last section 'The F8 Menu Functions' has the info I was referring to. archive.realvnc.com/products/vnc/documentation/4.0/win/… Hope this helps!
    – Rakly3
    Feb 27, 2020 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.