3

I'm coming from:

How to delete “System Volume Information” folder from external drives?

but unlikely that answer couldn't solve my problem. I've a copy of an old "system volume information" in my additional drive (not the WINDOWS HDD).

I tried to remove it with cmd as administrador, rmdir, doing takeown and other solutions but I couldn't. The content/names of the files are too long so it gives an error (Yes, I tried with short names but they also can't work)

Any suggestion to avoid this issue without downloading/using a big distribution of linux?

UPDATE 1:

This is how it looks after /rd command

enter image description here

By the way, "El nombre del archivo es demasiado largo" means "The filename is too long"

UPDATE 2:

System Restore disabled from the HDD with the issue enter image description here

12
  • 1
    Use Live Windows? :) Anyway, what's the error you're getting? Trying to rd /s /q just the System Volume Information folder tells you the path is too long?
    – Karan
    May 11, 2015 at 3:18
  • Well, I think if I could with Windows Live, I should with the installed windows, because the folder is not from the native installation, is from an old backup :) May 11, 2015 at 3:20
  • 1
    See my edited comment above. Also, did you try from a Safe Mode command prompt?
    – Karan
    May 11, 2015 at 3:20
  • 1
    @STTR: What service is that? It doesn't seem to exist on my PC. Leandro: Did you try disabling System Restore for that partition and then using rd?
    – Karan
    May 11, 2015 at 3:28
  • 1
    Honestly, instead of struggling with this so much I don't see why you can't download an 8MB ttylinux or 50MB Damn Small Linux, create a bootable LiveUSB using UNetBootin, boot from the same and get rid of the folder. You'd probably have accomplished all that by now and been back in Windows in the time it's taken you to post and update your question multiple times. :)
    – Karan
    May 11, 2015 at 3:38

2 Answers 2

1

Simply download a small Linux distro like Damn Small Linux or ttylinux, create a LiveUSB using UNetbootin, boot using the same and get rid of the folder.

3
  • 1
    NP, but I'm curious whether you tried doing this using Safe Mode with Command Prompt? Don't think you answered that question of mine. Another possible solution might be to boot into Windows RE (Recovery Environment) via F8 > Repair or from Windows installation media and then accessing the command prompt.
    – Karan
    May 11, 2015 at 3:46
  • I will try in the next reboot after finishing several tasks here, just to know, and I'll comment it. But I don't have too much hope in that option. I think this error will happen in any situation, being -system volume information- folder or any one. Indeed, I think I'll update the title in order to help further users with a similar problem. Windows.... sight May 11, 2015 at 3:50
  • 1
    Perhaps it won't work, but before booting into Linux there's no harm in trying and reporting back, both to satisfy our curiosity and also for future reference.
    – Karan
    May 11, 2015 at 3:51
0

You could also try one of the answers mentioned in Tool for deleting directories with path/names too long for normal delete.

In particular, I had success with the 7-Zip file manager multiple times already. If you managed to clear all the protective permission settings on that folder, 7-Zip should work seamlessly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.