0

SSH login take too much time in my CentOS machine, and also a ftp server is running on it.

Please help me to speedup the login time for both root and ftp user. I tried some tricks but no improvements.

Tries are shown below:

Already added some thinks into cat /etc/ssh/ssh_config

GSSAPIAuthentication no

UseDNS no

SSH login time is :

real 0m18.950s

user 0m0.022s

sys 0m0.016s

4
  • 1
    how much ram, what cpu, how much hdd space available, speed of NIC?
    – td512
    Commented May 11, 2015 at 6:31
  • 1
    Maybe this might help: serverpronto.com/accounts/…
    – Linux NewB
    Commented May 11, 2015 at 9:01
  • Are those config changes to ssh_config or sshd_config? It's often the server doing reverse dns that slows things up for me Commented May 11, 2015 at 15:13
  • Also, when connecting via ssh, use a couple of v parameters to make your ssh client give you some extra info for your troubleshooting. This may show you the bit of information you are looking for. Commented May 14, 2015 at 2:02

1 Answer 1

0

I had same exact issue, please make sure you server can reach the internet. Otherwise it will take forever to login via ssh or ftp/sftp and scp. I have tested this on my dedicated server while behind the firewall when no NAT was enabled for the server inside to reach the internet causing this kind of behavior. The minute we enabled NAT and host (server) was enabled to reach the internet issue disappeared.

I hope this helps for all folks with same issues. Tested on Centos 6 - 7 - 8.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .