0

I was away for the weekend and when I came back this morning my PC booted up just fine but I couldn't input anything via mouse or keyboard in Windows. I've already tried rebooting, different usb ports and changing usb settings in the BIOS - but neither has helped. In my BIOS screen both mouse and keyboard work just fine.

I'm on Windows 7 64bit and I have a wireless Microsoft Keyboard/Mouse-Set with a usb dongle (both use the same dongle). My mainboard is an ASUS H81-T. My Setup has been the same for over three month and I've never had any problem nor did I install new software recently. I even updated my BIOS because there was a newer one out and I hoped it maybe will fix the issue but sadly it didn't.

What could be the reason for this behaviour? Has anyone faced similar problems?

EDIT: Just tried another usb keyboard but it also did not work.

  • It sounds like the keyboard and mouse are wireless. Do they work fine before Windows boots? Stupid question, I know. – TheWanderer May 11 '15 at 14:08
  • yeah, they work fine in BIOS and when I boot some Linux distro off USB it also works fine. – farosch May 11 '15 at 14:10
  • Have you switched the ports while Windows is booted? – TheWanderer May 11 '15 at 14:10
  • 1
    You may need to boot into Safe Mode and see if the USB drivers get loaded so you can uninstall them (via Device Manager) -> reboot -> let Windows re-install them and see if it fixes the problem. – Kinnectus May 11 '15 at 14:16
  • 1
    @Zacharee1 - I was just going to ask that. Looking up the motherboard, it's quite recent so it doesn't have PS/2. This is going to be quite hard to fix... can you remotely control your machine? Remote desktop? You could remote into it to uninstall/re-install the hubs. Alternatively you may need to buy a cheap PCI card with USB ports on. This will prompt Windows to install different drivers but at least you'll have some working USB ports... – Kinnectus May 11 '15 at 14:30
0

I was able to remotely log in onto my machine using Microsoft Remote Desktop (RDP). The Device Manager was showing two exclamation marks for two USB Root Hub. I deleted those two and rebooted. Windows then reinstalled the USB drivers and my mouse and keyboard are working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.