2

I would like to update bios on my T61 but unfortunately battery died back in the stone age. The whole notebook is a Dual core T7100 1.8 Ghz Centrino Duo without Nvidia graphic card (it has intel integrated GMA) and with 2 gigs of ram. The laptop dates back to 2006 or 2007 if i remember well.

The problem is that whenever i want to update the bios using a bootable CD or pendrive I get a message like 'Error, battery not connected'. Basically the whole flashing process don't even begin due to the fact that battery is completely unusable.

What I've tried :

  1. Use Winflash by Phoenix after booting up the system, rename original fl1 files that come with lenovo t61 bios update online source to bios.rom and platform.bin. Program returns 'error 104 BIOS image checksum verification failed' for both official and un-official bios roms.
  2. Use Phlash16 dos program under initial boot-up command line to execute an updating process.
  3. Used /forceit command to somewhat bypass the battery status check as instructed in one forum board.
  4. Tried Middleton un-official bios for Lenovo T61 as well as official Lenovo T61 2.09 bios update.

Goals:

  1. Disable whitelist check for various notebook components.
  2. Install apple macbook's wifi card inside the Lenovo T61.
  3. Install Mac OS.

Questions:

  1. I would like to ask how can I bypass this problem without the necessity of purchasing a brand new battery from store ?

  2. Is it safe to perform flashing only with AC adapter cord plugged in and without the help of battery as an additional source of energy ?

Thanks !

4
  • 2
    If the AC cable is plugged the battery isn't going to be used for "additional" source of energy. Have you tried removing the batter and just performing the update on AC power? – Ramhound May 11 '15 at 18:17
  • Didn't try yet due to the fact that I got an error message before stating 'no battery is connected'. Thus I didn't even try removing it as I thought that if the battery is not detected and it doesn't let me pass through the updating process then removing battery won't make a difference. – Danny_Student May 11 '15 at 18:35
  • At the worst, a new battery is ~US$13, e.g. amazon.com/Laptop-Battery-42t4566-42t4569-Thinkpad/dp/…. – DrMoishe Pippik May 11 '15 at 19:08
  • Sure, but I treat the whole case as a challenge for me. I want to find a way to bypass the whole issue and trick my computer into thinking that battery is all fine or at worst - to force update by proper editing of certain files. – Danny_Student May 11 '15 at 19:12
0

I think the battery is not your main problem, and with winphlash it should work.

Download a new version of Winphlash

And for my lenovo without battery following steps worked well:

  • files .FL1(BIOS) and .FL2 (ECP: Embedded Controller Program / platform)
  • executables with a name similar to winphlash (can be DOS or windows)

winphlash can backup current BIOS and apply a BIOS with extension .ROM and will not check for battery.

The .FL files have the format required by winphlash, so you can rename the extension FL1 to ROM or just force the filter to pick the FL file

very important ECP should always be flashed before than BIOS file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.