2

I am not sure this is the best place to ask this question, but I am stuck and hope to get some hints from the knowledgeable community. I am having hard time making my DLNA home audio system work.

Hardware configuration

My music collection is stored on a Synology DS414 NAS with Media Server for DLNA support. It used to be connected via Powerline adapters, but now, for the sake of speed, I have connected it directly to the router.

There are two main renderers:

  • Samsung Smart TV (connected via WiFi)
  • Marantz NR1504 AV receiver (connected via Ethernet)

Android smartphones are mainly used for playback control with BubbleUPnP.

Network is provided by an Ethernet/WiFi Technicolor TC7200 router.

Problem description

Until about a week ago, the whole system was working fine, with the NAS connected to the network via Ethernet-Powerline-Powerline-Ethernet. I was able to browse the music collection on the smartphones as well as on the TV and the receiver, and I could make the smartphone take the music from the NAS and play it on the receiver.

Then I connected the NAS directly to the router (for faster file transfer, since Powerline seemed to be a bottleneck). I am not sure if the problem appeared immediately and if it is connected to this change of networking at all, but now:

What works:

  • The TV sees the NAS and has no problem accessing the files. It can also play them via ARC using the AV receiver.
  • Media Player can playback local files both locally and to the AV receiver.
  • BubbleUPnP app can play the local smartphone library locally and to AV receiver.
  • Media Server on Synology can see all DLNA devices:

    List of DLNA devices visible to Synology DiskStation

  • Audio Station on Synology can playback to AV receiver.

What doesn't work:

  • Most importantly, neither the AV receiver, nor the BubbleUPnP app can see the NAS.
  • Windows Media Player can see both the Synology:

    Media Player library list

    but when trying to playback, it gives an error:

playback error

After this, the NAS disappears from the list of libraries and will re-appear after Media Player restart.

So it looks like Synology became practically invisible as a DLNA server (smartphones and AV receiver do not see it, and the Windows computer sees it at first but gives error when trying to playback), except for the fact that the TV sees it perfectly well.

I wonder if there is any way I can debug this situation besides trying to restore the previous configuration and trying all over again. It would be difficult, since all these devices are regularly updating themselves, so the problem may potentially have been caused by one of the updates.

2

Just something to try, switch off your samsung tv and try again. I have a Marantz NR1506 that only sees my dlna server with the samsung tv switched off or with the ethernet cable unplugged from my tv. (i don use the wifi on the tv)

  • Tried, doesn't help. – texnic Mar 12 '17 at 22:30
1

Just to share my experience. I had a similar problem. DLNA players like my smart TV did not see the Synology DLNA media server or the connection dropped after some time. Restarting the media service sometimes helped. The Synololgy NAS was connected to my ASUS AC87U router. It looks like this built in switch somehow interfered with the SSDP traffic. I changed the network cable to an external simple unmanaged switch and the problem is gone. All my media players now again directly see the media server :-)

0

I eventually solved the problem by reinstalling Media Server. It has readjusted the firewall settings. So maybe the problem was there. Now my receiver sees the Diskstation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.