1

I installed the trial of ExtFS 9.7.109 on OS X 10.10.3. It worked great for the first 3 days. But now my ext4 drives no longer show up.

Last thing that worked was copying data from an ext4 drive. Strangely, folders moved in Finder were not complete. The ext4 drive showed files not moved. I tried a few times again and eventually it was fine. But on the next reboot the two ext4 drives disappeared.

I do not suspect the drives as Diskutil can still see them. Also, installing OSXFuse also works fine. I can copy data that way. But no write of course.

I tried reinstalling ExtFS several times but nothing works.

I looked in the console but saw no errors from ExtFS.

How do you suggest going about debugging this?

  • Are these drives usable from Linux? Have you tried running fsck on them, and if so, did it give any errors? – jpaugh May 13 '15 at 3:16
0

That was it. Another Evil Seagate drive coughing up blood. Ran fsck on it and 10 min later it was bad again... That's 4 bad Seagate drives in the past year!

It would be nice if ExtFS could be a bit more obvious with the error. Instead, it just refuses to mount any of the drives. But at least I know how to fix it...

I don't think the problem is related to ExtFS. The drive kept corrupting even on Linux...

  • Hmm.. You might consider buying an "enterprise/commercial" drive. I consider them overpriced, but a friend of mine swears by them. YMMV. – jpaugh May 14 '15 at 23:36
  • In a past business I used a a large quantity of Maxtor enterprise drives (hundreds). I also had unreasonably high failure rates. So I think that proves a single model's defects outweighs the enterpriseness of the hardware. Maxtor was bought by Seagate so maybe I should not be surprised... Seems those drives are just bad news in general. I'm trying HGST now. It's just sitting on a desk holding data (not OS). So it's not like it's working hard. The last dead Seagate showed only 6 months of power on time... See: backblaze.com/blog/hard-drive-reliability-update-september-2014 – PrecisionPete May 19 '15 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.