I've got a chicken & egg problem. I'm a remote worker and I just received a new machine. I still have my previous machine, which is connected to my corporate network via VPN. On my new machine, I can't sign in because:

  • My machine can't access a domain controller to perform the first logon
  • I can't log in to set up the VPN.

I thought I might be able to share the VPN connection via my old machine, so I took these steps:

  • Set up a hosted network on the old machine's unused wireless adapter, using netsh wlan set hostednetwork mode=allow ssid=nsakey password=backdoor
  • Started the hosted network with netsh wlan start hostednetwork
  • Opened the settings for the VPN adapter in Network Connections, and enabled Internet Connection Sharing with "nsakey" home networking connection.
  • Connected to nsakey network using the new machine
  • Entered domain credentials
  • Grimaced in defeat

I tinkered around with opening up kerberos & ldap ports 750 and 389 through ICS as well but that didn't help either; those were just guesses.

Is this something I should be able to do? Are my steps sound?


Have you tried bridging the connections via network and sharing center? Also connect w/ a smartphone and see if dhcp is working. You need the right DNS server to see the domain.

  • I did try bridging--for the record, between the VPN adapter and the wireless network adapter that the new machine is connecting to via hostednetwork. Under these conditions however, my VPN client on the old machine is no longer able to connect, nor can my phone connect to the hostednetwork. I've never really known how bridging works--maybe I chose the wrong adapters to bridge? – bwerks May 13 '15 at 16:27
  • Interesting. That shouldn't kill your ability to be connected to the VPN. It's possible but sounds like you did it right ... unless your hosted network generates a new adapter. The way you're doing it now with ICS, I would see if there is a way for you to change the client computer's DHCP options to manual, pick out a good IP address, etc. Then see if it wants to behave. – Arthur Kay May 13 '15 at 20:17
  • Starting the hostednetwork does indeed create a new network adapter, yeah--this is in part what is so confusing since ICS can target both the "real" wireless adapter and the "virtual" hostednetwork, and the correct one isn't clear. For my purposes though I tried both and neither did the trick. – bwerks May 13 '15 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.