0

I have an Acer Aspire E3-111 which is an Intel based laptop. It uses Celeron N2830 with Intel HD Graphics.

The laptop has HDMI port. My only problem is that the LCD flickers when I connect to a 1080p monitor. It is impossible to keep the laptop LCD and monitor enabled at the same time. The monitor would stay blank and LCD would cycle between screen and black.

I have to either unplug the HDMI and use laptop LCD only or close the laptop (must also disable sleep on lid close) and use external monitor only. Any ideas what went wrong?

  • Latest graphics drivers installed from Intel's site? – Karan May 14 '15 at 5:30
  • Sadly, the generic Intel driver will not install. Saying my driver is manufacturer customized. I even tried following the instruction to manually install the driver from the driver directory but Windows still says I have the latest. – some user May 19 '15 at 23:43
0

Answering my own question. I believe I have found a solution. It is either a combination of both a/b or just one of them:

a. Set the external monitor to Extend Desktop. This is easier said then done because the selection is not available until monitor is plugged in and the driver remembers the setting by monitor. The screen will went blank shortly afterward and the option will also be gone. The procedure is

  1. Start at external monitor only mode (lid closed)
  2. Open the "Screen Resolution" window (right click on desktop)
  3. Open the lid
  4. (There is about 5s window to do this. So do it quick!), the window will refresh and you have a choice of "Extend Desktop". Choose it! Hit Apply. A window will pop up and you need to confirm the setting is okay.
  5. After that, desktop will be extended. And both display can be used at the same time.

b. The 2nd thing I do, which maybe important, is that I also open up Intel's Display Utility. Inside its Display Property, my external monitor is using 59Hz. I changed it to 60Hz. It is possible that the flicker is because the external monitor and laptop LCD cannot agree on some common setting.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.