0

One big advantage of Virtual Machines is the fact that they are somewhat independent of the underlying hardware. My goal is to have a Virtualbox image on an external USB-drive that I can use with different host systems (some of them are Windows 8.1, some Debian Linux).

In the past this has worked fine, but with the latest releases of Virtualbox the Windows host refuses to start an image created on the Linux host because of the "already existing" image for the VirtualBox Guest Additions. (Of course the path of them is different in Windows from the one in Linux).

So the question is: What configuration settings are necessary for an image to be usable across several host systems?

It is clear that the image has to be stored on a filesystem that can be read and written by all host systems, so this is NOT the scope of my question.

Error Screenshot

exact Error text:

Konnte die virtuelle Maschine in E:/virtualmachines/Wheezy-Test1/Wheezy-Test1.vbox nicht öffnen.

Cannot register the DVD image 'C:\usr\share\virtualbox\VBoxGuestAdditions.iso' {7fbf3153-636d-4496-9bea-da60ebb6f8ba} because a CD/DVD image 'C:\usr\share\virtualbox\VBoxGuestAdditions.iso' with UUID {ac809a6e-292f-4cb4-81c4-bc57caa2f595} already exists.

Fehlercode:E_INVALIDARG (0x80070057)
Komponente:VirtualBox
Interface:IVirtualBox {fafa4e17-1ee2-4905-a10e-fe7c18bf5554}
  • have you tried dismounting the tools disk from the CDRom device before shutting down to switch to another host? – Frank Thomas May 13 '15 at 13:40
  • how about you state the exact words of the error re guest additions (rather than taking it as gospel / anything more than an error message), and maybe others have run into that error message and find things to do re it. – barlop May 13 '15 at 14:38
  • I'll provide the exact phrase as soon I have access to the host today in the evening. If I remember correctly, I had dismounted the device but I'm not sure if the device got remounted upon the next startup/shutdown cycle and will also check this evening. – mschenk74 May 13 '15 at 14:41
  • Now I've checked it again: If I try to unmount the tools disk it only allows me to do a "force dismount" and not a normal "dismount". After doing that on the linux host and switching to the windows host I still get the error message shown in the screenshot and pasted to the question. – mschenk74 May 14 '15 at 9:51
1

It is more like a workaround than a real solution:

Since the dismounting of the GuestAdditions via the User Interface didn't work (see my comment above) I had to edit the .vbox file and changed the <DVDImages> ... </DVDImages> element to an empty <DVDImages/>. No I still get the warning that there is no GuestAdditions-Image available but at least the VM can be started now. (And adding the GuestAdditions should be no problem if needed)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.