6

From time to time I want to copy and paste a portion of a web document (viewed in both IE Explorer 7 and 8) into MS Word 2007. The selected text copies and pastes fine, but I am left with only place holders for the images (png). Right clicking the image and clicking copy, then pasting into MS Word doesn't work either. If I paste the image into MS Paint and copy it from there, I can paste it into the Word document. What gives?

  • Have you tried with another browser? – Charles Stewart Jan 19 '10 at 10:26
  • I should try Firefox - I already have it installed. I also tried pasting into Openoffice Writer. It has the same problem. – Les Jan 19 '10 at 15:47

11 Answers 11

2

In Word 2007 I always had a problem when copying webpages into it. The page would not fit, and go outside the columns, etc. until I found this:

  • Copy
  • Paste,
  • Then select: Page layout
  • Select: Web layout
|improve this answer|||||
1

Right click and Copy might not work in all cases as described by John that they maybe behind some web-based authentication. Try selecting them by dragin the pointer around them, just like you select text and then press CTRL+C.. Go to Word, and Paste.. Should work.

|improve this answer|||||
1

There are some options in Word 2007 that you should check. For instance: Advanced > Show Document Content > Show Picture Placeholders.

Another factor is the view you're using in Word. Some views, like Draft, don't show images normally. Try switching to Print Layout view.

|improve this answer|||||
1

If the selected images are behind some sort of web-based authentication, Word will send another request for the image which fails. Word will follow IE's setting for this.

I'm not sure on the exact location of it in IE8, but in earlier versions it was under Tools -> Internet Options -> General tab -> "Settings" button under the Temporary Internet Files section. You'd get an interface similar to this:

enter image description here

Where it says Check for newer versions of stored pages, set it to Automatically.

|improve this answer|||||
  • My setting was already at 'Automatically', and copy/paste works from this web page, but not from the pages that have been causing problems. – Les Jan 5 '10 at 13:06
  • @Les, since it works with some pages and not others, perhaps give some example urls where it does and doesn't work for you. – matt wilkie Jul 19 '10 at 16:08
1

There are two things that you want to do:

  1. Copy the text and the pictures together
  2. Copy the text first and then right click->Save Picture As..., choose a .jpeg file. Then after that, go to Microsoft Word, select Insert->Picture->From File..., then select the file from your C: drive or wherever it was saved
|improve this answer|||||
0

Save the web page as mht file from Internet Explorer. Edit the file in MS Word. Now you can also copy past from one file to another MS Word file.

|improve this answer|||||
0

Do you have the Drag and drop or copy and paste files option set to Enable?

You can customize IE security settings for internet zone :

Tools | Internet Options | Security 

Security Settings - Internet Zone

|improve this answer|||||
0

The ability to copy text and pictures into Word from a web page depends on the browsers layout engine. Today there only seems to be a choice between Trident, Webkit and Gecko and only Trident will enable you to do this. I found that an earlier version of Word enabled pictures to be copied at the same time as text. I think it was Word 2002. Otherwise only the placeholders for pictures are copied and each picture has to be copied and pasted into it's respective placeholder. I found that other word processors like Open Office scramble the formatting of the original web page during the pasting operation.

|improve this answer|||||
0

Bring the web image and/or text in the web page to the center of the screen. Press PrtSc. Open Paint in Accessories and paste with Ctrl+v. Select the required area and copy by either Ctrl+c or by right clicking. Then go to your word document page and paste with Ctrl+v. Your job's done. That's it!!

Ash.

|improve this answer|||||
  • 2 problems with that. There are a few dozen pages of text. The text would not be searchable. – Les Mar 17 '14 at 16:14
0

Do not paste directly. Copy the picture from the browser and then do the following steps:

  1. In the Home tab in the Clipboard group, click on the arrow below Paste.
  2. Click on Paste Special
  3. Select the Bitmap option.
|improve this answer|||||
0

To make it:

1) From the browser, first export the page with document to be copied (as complete html: secondary mouse button "Save as complete web page").

2) Open word, Open file: that exported html. That result can be selected total or partially, copied and pasted to any MS Word, with all the images visible.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.