1

I have an UEFI-motherboard - ASUS P8Z77-MPRO. It supports CSM(Compatible Support Module). My Win7 is installed in BIOS mode, I've checked it. This because, I must install ArchLinux in the same way(BIOS) to avoid problems with dual-boot system as said in the documentation. But when I'm booting in with my USB it enters in UEFI-mode installation:

enter image description here

I changed the state of CSM from "Auto" to "Enabled", marked "Fastboot" as "Disabled" and so I did with "SecureBoot" (Actually, the last one was aslready been marked).

How can I boot with USB not in UEFI mode?

  • @Ramhound, do you mean my software like x64, x86 or you're talking exactly about hardware like "i7, GeForce 650" etc. – pushandpop May 14 '15 at 11:36
  • You need to name at least your motherboard’s (exact!) make and model. Also, how did you create the bootable USB drive? – Daniel B May 14 '15 at 12:42
  • @DanielB, I've used Rufus but it didn't work out, then I picked USBWriter up and it works. I'm using software from the official guide on ArchWiki – pushandpop May 14 '15 at 12:56
0

Depending on the model of your motherboard (please state your model) you should be able to go into the bios and with your usb device attached, set it as a boot device. There may be additional UEFI features you need to disable, but without your model it's hard to know.

  • It's ASUS P8Z77-MPRO – pushandpop May 14 '15 at 12:54
  • This should help: eightforums.com/tutorials/… – Volumetricsteve May 14 '15 at 13:03
  • I tried this, and as I've mentioned before it didn't help. – pushandpop May 14 '15 at 13:06
  • Sorry, I didn't realize you'd followed those exact steps...that's actually what did it for me on my Asus board. I'll let you know if I find anything else – Volumetricsteve May 14 '15 at 13:14
  • This is strange...I can't find clear steps to disable uefi, but the odd thing is I had a hard time getting uefi to work! I'll run some tests on my Asus board in the next day or so and hopefully find something that can help you. – Volumetricsteve May 14 '15 at 13:19
0

For Arch, you should be able to install in EFI/UEFI mode and boot in BIOS/CSM/legacy mode. Unlike distributions with more automated installation procedures, Arch's installation instructions specify manual selection and installation of the boot manager. Because BIOS-mode booting relies (almost) exclusively on disk-based data, it's possible to fully set up a computer to boot in BIOS mode from an installation medium that's booted in EFI mode, provided the mechanism to do this is not automated in a program that ties boot loader type to the current boot mode.

  • Hm, I'm gonna give it a shot right now. I will leave feedback as soon as done. – pushandpop May 14 '15 at 16:13
  • I've installed ArchLinux. But got stuck at "os-prober" stage. It doesn't see Windows7 when running 'os-prober' command. I think this is because Win7 was installed in bios mode, when ArchLinux is being installed in EFI (as picture above shows). Am I right that os-prober produce an ignore to me because of different boot mode installation? As we had discussed I can't change the installation mode to not-EFI. – pushandpop May 15 '15 at 13:23
  • I've just noticed that version of my BIOS is outdated. I'm gonna update it and see will it work or not.. – pushandpop May 15 '15 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.