4

This post was originally posted on StackOverflow, where users recommended reposting here.

I'm currently mounting remote server directories as local folders under OS X 10.10.3 and OSXFUSE + SSHFS. When trying to edit these files with Sublime Text 3, simple edit operations are very slow. Even typing in characters has a 1-2 second delay before the characters appear in the document. Opening new files sometimes causes ST3 to hang for a minute.

In contrast, when opening the same files in vim (locally, on the SSHFS mount), editing them, and saving, I encounter no delays or problems.

Is there some reason I am encountering this slowness from ST3? How come vim does not encounter the same problems, in the same setting. Are there some configuration options I can set to avoid this? If the problem is plugin related, is there some way of troubleshooting which plugin is causing the bad behaviour?

I tried setting "atomic_save": false in my config, as suggested in some other StackOverflow posts. This helped a little, but there are still lag problems, so it did not completely resolve the issue.

  • Do you have a Git related plugin installed? Those are especially slow via SSHFS. – nh2 Jan 12 '16 at 11:15
0

For future reference, the comment by nh2 in OPs post was helpful for me. The following did the trick:

"ignored_packages":
[
    "GitGutter"
],
| improve this answer | |
0

What worked for me was to disable indexing: after a restart it worked like a charm:

{
    "index_files": false
}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.