3

I replaced the front panel PCB on my desktop computer when I pulled on the headphone jack and broke it. I got a new one (warranty replacement from the OEM) and installed it. I double-checked that everything is hooked up correctly and that I attached the grounding wires precisely how they were on the original PCB. However, with the new PCB, I'm seeing this behavior consistently with the headphone jack.

(From an initial state where Windows has the headphones and speakers devices enabled, and my desktop speakers are connected to the rear panel port at all times. Headphones are unplugged.)

  1. Sound works fine and comes out of my desktop speakers.
  2. I plug the headphones into the headphones jack on my front panel. Windows detects the headphones and sound comes out of them, disabling speaker output.
  3. I unplug the headphones. Windows does not detect the headphones being unplugged, still sends sound to the headphone jack, and the desktop speakers remain silent.
  4. I go into Playback Devices and see the headphones still listed as "plugged in". I disable them, and then Windows outputs sound from the desktop speakers again.
  5. I re-enable the headphones device in the Playback Devices window, and Windows detects the headphones as unplugged.

After step 5, the headphones' status will remain as unplugged until I plug them in again, at which point the whole process starts over again.

I would like to not have to go through the disable/enable device dance every time I unplug headphones from the computer.

I mentioned that I double-checked all my connections from when I installed the PCB. It didn't look obviously damaged or different from the original. I re-fastened all the ground wires and went over everything again.

What else could be going on? Is it likely that I missed something when connecting the ground cables? Is something dirty or is there something I can tweak to fix it? Is the PCB I got as a replacement faulty? Or is this something that can be fixed in software?

  • Is the headphone socket on the new PCB the same type because many of the "auto-detect" capabilities are because the socket has a spring-style switch that when you plug headphones in they open or close a circuit that the soundcard detects and your OS is notified. If this "spring" mechanism is missing (or broken in some way) then the result may be unpredictable or causing you to do what you're having to do... – Kinnectus May 20 '15 at 10:16
  • @BigChris The PCB is exactly the same as the old one, as it is a warranty replacement from the OEM. – Ben Richards May 20 '15 at 14:46
  • Would they send you another replacement to see if the one you've been sent is faulty, too? – Kinnectus May 20 '15 at 14:49
  • Honestly this sounds like more damage was done beyond just the PCB – Ramhound May 20 '15 at 15:00
3
+250

This is definitely a hardware issue, do not waste your time anywhere else. Either your replacement is faulty or probably dirty; you should try some compress air and see before replacing the just added pcb for a new one.

As a reference you can see here a "similar" issue also with a RealTek

3

Try to uninstall the Sound card drivers and reboot :

  1. Start the Device Manager
  2. Expand Sound, Video and Game Controllers
  3. Right-click the sound card driver and select Uninstall
  4. Reboot to reinstall drivers.

If that doesn't work, check if in Windows Update there are any optional updates that relate to the sound card and install them.

If still no go, search for a driver on the website of the card's manufacturer.

If nothing works, give us some more detailed information of the make of the sound card and what the Device Manager thinks it is.

However, Occam's razor says that if the hardware worked correctly before it was fixed, then the fix itself is the suspect here. You might need to have your fix checked by a professional repairman.

  • I have tried uninstalling and reinstalling the audio device and drivers. It is a Realtek chipset and I am not using Realtek's software because I dislike how it handles multiple audio devices compared with Windows' own "vanilla" drivers. Windows Update is also clean. – Ben Richards May 18 '15 at 21:32
  • Try the Realtek drivers as a last resort to software. If this doesn't work then I would say that this is a hardware problem. Such problems are almost impossible to treat on this forum by remote control. – harrymc May 19 '15 at 6:24
-2

Did you use cables with a other diameter than the original cables? I guess (I'm no expert!) that your computer checks for a changing electric resistance and thinner cables would have a higher resistance what could not trigger a threshold in the system. You could try to wire the ground cable to another ground (maybe you - hold it in your hand (it should be safe, I guess - do not trust me on this)) or fix it to your radiator or any other mounted, unisolated metal. Good Luck!

  • This looks like a software issue, not electrical. True, the resistance of a wire is inversely proportional to the wire's cross-section - so thinner wires should have more resistance than thicker ones using the same materials. But in these current rates and voltage, I highly doubt that resistance has anything to do with this problem. – matan129 May 19 '15 at 21:36
  • change in resistance due to small changes in cable thickness is only noticeable in "long" cables... – Pat May 20 '15 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.