0

Using a Windows 7 host and a PPTP connection I've been unable to get the VPN working with a VM running a RedHat Linux derivative. Sharing the host's PPTP connection with VirtualBox's host-only network seems to break any connection to the host and the VPN.

Trying to connect to the VPN from within the VM appears to work with VirtualBox's bridged adapter, but after establishing the connection resources inside the VPN are still inaccessible. The "netstat -rn" table lists the VPN as the first destination which is what I'd expect. Yet "tracepath" commands all appear to be using localhost, the non-VPN connection, or get no reply.

netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.x.y.z        0.0.0.0         255.255.255.255 UH        0 0          0 ppp0
207.x.y.z       192.168.x.1     255.255.255.255 UGH       0 0          0 eth0
192.168.x.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
0.0.0.0         192.168.x.1     0.0.0.0         UG        0 0          0 eth0

Using Windows' network bridging from it's PPTP adapter appears to be out of the question. The host consistently works with the VPN. I've also tried disabling the guest VM's firewall entirely.

EDIT: Included routes.

0

Found the solution to use the PPTP connection with the VM at https://www.centos.org/forums/viewtopic.php?t=26810

What I had been missing when I tried to connect within the VM:

2.3 If /sbin/route shows that there is default route for current network connection, we have to add another default route for ppp0 to be able to use the vpn. This is because pppd's defaultroute option does not override existing default (by design). The ip-up.local is a script that is executed after the connection has been established:

create file /etc/ppp/ip-up.local and add the following:

/sbin/route add default ppp0

make ip-up.local executable:

sudo chmod 755 /etc/ppp/ip-up.local

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.