0

I have a litle question about launching emacs using this command

xfce4-terminal -e "emacs -nw"

I'm using TERM=xterm-256color in my .bashrc but it has effect only when i first launch a new xfce4-terminal before calling emacs -nw in two separate steps.

And of course, the reason I need this, is for launching emacs in a new terminal using hotkeys (lxde) with 256 color support. I tried many different solutions (.sh scripts, etc) but none has worked.

Thanks in advance.

1

Using

xfce4-terminal -e "emacs -nw"

you are not running bash — rather, you are running emacs directly. So your shell initialization is not used.

If you want to ensure that bash is run, you could do something like this

xfce4-terminal -e "bash -i -c 'emacs -nw'"
  • no problem (the odd quoting appeases both programs). – Thomas Dickey May 17 '15 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.