0

I'm bootstrapping some servers over serial. I've been using PuTTY on Windows, but I'd really rather use Linux.

In PuTTY, I can simply select serial and enter the baud rate. A serial window pops up and away I go, I can login and start configuring.

PuTTY works on Linux, but I'd rather use a command-line application if I can. It seems that minicom is a common Linux CLI serial client, so I though I'd try it. However, it all seems a good deal more complicated. (So many bells and whistles!)

How can I get minicom to do the same things PuTTY does?

| improve this question | | | | |
2

To change the serial port bit rate and such, hit Ctrl-A P or Ctrl-A O. The first takes you to a screen that lets you change these settings only, while the second second takes you to a higher-level menu that offers a way to change those settings and more.

Note that in the lower-left corner of the window, you were offered "Ctrl-A Z for help". The resulting window lists all of these special keystrokes.

Minicom and PuTTY really aren't all that similar. They're both terminal emulators, but Minicom follows in the footsteps of old DOS modem programs like Telix and ProComm, whereas PuTTY is primarily an SSH client that also happens to have raw serial communication ability.

One place this difference shows up is that the default init string in some minicom packages is a Hayes AT modem command string, which is sent immediately on program startup to the default serial port. This may annoy whatever is connected to the other end of the line, if it is not in fact a modem. You should check for this in Ctrl-A P → "Modem and dialing". Clear out the Init and Reset strings, if they aren't already.

| improve this answer | | | | |
  • For some reason, I can't seem to get minicom to send my input correctly. (The server just waits as I try to log in. I assume it doesn't get my input for some reason). Do you have any idea why that would be? – PythonNut May 17 '15 at 21:18
  • 1
    @PythonNut: The fact that you can see the login prompt at all tells you that the cable is working and that you have found the correct bit rate, parity and stop bit parameters. Wild guess: you still have hardware flow control enabled, and the cable doesn't have those signals wired up correctly. Try disabling it via Ctrl-A O, Serial port setup. This is necessary with "3-wire" serial cables, so named because they only have the RX, TX, and GND signals wired. – Warren Young May 17 '15 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.