In past versions of OSX you can toggle between mirror displays (if you have more than one monitor) and extend displays with the keyboard shortcut (Command + F1). In Yosemite however, when I try to use this shortcut, my mac just makes that "thunk"/"beep" kind of warning sound like when you try to move a file to the trash if the file is still open and the display does not get mirrored.

I checked in system preferences > keyboard > shortcuts > display and there are only two shortcuts listed there:

enter image description here

There is no + button to add a keyboard shortcut because Apple says it will not allow you to create custom keyboard shortcuts for anything except "App Shortcuts" but this is not an app shortcut. It's a system shortcut. I have never modified any of the shortcuts for anything on this machine. Where did the shortcut for toggling mirror displays go? Why is it not displayed in the options on this panel? Did they remove it in Yosemite or is there something I need to do to get it back?

I've looked through the other panels (Services, Spotlight, etc.) but I don't see this shortcut or any other shortcuts for the keyboard listed under any of them. It seems to me like there should be a few more than just two keyboard shortcuts right? How can I get the "Toggle Mirror Display" shortcut?

  • Curious, this page on Mac Keyboard Shortcuts lists CommandBrightness Down "Turn display mirroring on or off when your Mac is connected to more than one display." (?)
    – MrWhite
    May 18, 2015 at 15:50
  • Ah, I see... This is interesting. I'm using a 3rd party keyboard so maybe that is the reason why my keyboard shortcuts are so limited. I'll try with a mac keyboard when I get the chance. May 18, 2015 at 16:01

1 Answer 1


Figured it out thanks to comment from @w3d. The problem was because I was using a 3rd party keyboard. Mac keyboards have specific keys set aside just for performing system functions like adjusting display brightness and music settings. Some of OSX's keyboard shortcuts are tied to these function keys and if your 3rd party keyboard doesn't have function keys, OSX will not even display those shortcuts under the display panel. I did not switch to a mac keyboard, but instead downloaded a program for key remapping called "Karabiner" which allowed me to change the purpose of the F1 key (I don't think I've ever pressed F1 before in my life anyway so might as well make use of it) to adjust display brightness. I was then able to use all shortcuts associated with that key as mentioned by @w3d. Problem solved.

Side Note: It seems counter intuitive for Apple to tie important keyboard shortcuts to keys that 3rd party keyboards may not have. What makes it worse is that they don't even display the keyboard shortcuts (they could easily still display them and just gray them out if they are not available) if your keyboard doesn't have the function keys. I get they are trying to make money and have people purchase more of their crappy keyboards but if that was your scheme then why not let the user know that more shortcuts are available with a mac keyboard by displaying them as blocked in the shortcut menu? Stupid Apple. I've been trying to figure this out for days!

  • Seems like I have this issue with Catalina and Logitech keyboard as well. I tried to remap F1 key in Karabiner, but it didn't help me. Maybe I'm just doing something wrong, maybe it doesn't work any more. Can you please explain what needs to be done?
    – Micer
    Oct 21, 2020 at 21:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .