0

So i downloaded these files from Bulgaria. They are the english version of the demo files for a programming tutorial. I noticed that when i try to rename the folders, each keystroke results in Russian(?) characters instead of Latin.

When i open notepad, i get the normal Latin characters. How to fix this?

It also occasionally happens in text editor programs (Notepad++, Visual Studio, Arduino IDE) but the above problem is persistent.

Notes:

I only have English and Japanese language packs installed.
Just recently scanned my Windows installation with the latest Avast (free) virus definition.
  • Go to Region and Langauge > Administrative and tell me what the non-Unicode system locale is set to. Did you check to see that you do not have any Cyrillic keyboards in your input languages list? – oldmud0 May 20 '15 at 0:45
  • Bulgarian is very similar to Russian. – Konrad Gajewski May 20 '15 at 0:52
  • @oldmud0 the system locale (for non-unicode) is set to English – WikiWitz May 20 '15 at 0:54
  • What were the files you downloaded: .exe files for each sample, an installer, a downloader..? – oldmud0 May 20 '15 at 1:10
  • they're just compressed source codes visual studio projects – WikiWitz May 20 '15 at 1:21
0

Yes this is a trivial matter but it is annoying and counter productive if you're working on something (and Google can't help).

Figured it out:

Windows 7:
Control Panel > Region and Language > Under "Keyboards and other input languages" click "Change keyboards..." > Advance Key Settings

Under "Hot keys for input languages" i have the key sequence Alt + Shift set for switching between input languages. Although i only have the English input language in the options for the Default input lang. This hot key switches the input lang.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.