4

I have unsolved problem with my macbook. Once when my mac was alive, I've set rights to all data on mac HD for user 'system' to read-only. Also I do it for the groups 'wheel' and 'stuff'. Only one user account with name 'mac01' has all rights to data on my mac HD. After this (why I made it, I can not explain, it's my fault) my mac goes down and can not boot the system. As decision, I run system in Single-User Mode and type:

fsck -f
mount -uw /
chmod -R ugo+rwx /

But it still not help me. System still can not boot, and stops above 55% loading apple logo screen.

In Verbose Mode the last string is:

en0: channel changed to 1

then boot stops for unknown time.

Please, help me if you can. I would be appreciate for your help! Thanks.

OS X boot - en0: channel changed to 1

The last lines in the verbose mode are:

IO80211AWDLPeerManager::setAwdlOperatingMode Setting the AWDL operation mode from SUSPENDED to AUTO
IO80211AWDLPeerManager::setAwdlAutoMode Resuming AWDL
en0: BSSID changed to 28:28:xx:xx:xx:xx
en0: channel changed to 1

and it hangs/freezes.

I did run in recovery mode, run Disk Utility, fsck and verified/fixed the permissions, but it didn't help.

  • Run system in verbose mode and check on what part it's freezes and type the error you've got. – kenorb May 20 '15 at 13:44
  • last string in Verbose Mobe is: "en0: channel changed to 1" – Norman Volt May 20 '15 at 13:48
  • and then boot stops for unknown time – Norman Volt May 20 '15 at 13:50
  • Can you try to run in recovery mode? Then run Disk Utility and 1. Fix the errors on your HDD (it could also fix common boot problems), 2. Verify and fix the permissions. Because chmod -R ugo+rwx / wasn't a good idea to do. – kenorb May 20 '15 at 13:52
  • I try but this can not help, system still can not boot OS – Norman Volt May 20 '15 at 13:54
8

I've set rights to all data on mac HD for user 'system' to read-only. Also I do it for the groups 'wheel' and 'stuff'. Only one user account with name 'mac01' has all rights to data on my mac HD.

If you messed up with OS X permissions, normally you should run Disk Utility in recovery mode and run Repair Disk Permissions and Repair Disk or First Aid (in El Capitan) to correct errors on HDD and eventually fix the boot loader. In most cases it should work.

To fix it manually, you should run in single mode and try to fix it the permissions on system folders manually, for example:

chown -R root /System /Library
chmod -R u+rwX,go+rX,go-w /System /Library

and then type exit to continue the startup process and note any meaningful errors.

If this won't help, here are the things to consider:

  • disconnect any external devices that are connected (if any),
  • try to run your Mac in Safe mode,
  • check for fresh core dumps /cores (this could indicate some problem with specific component),
  • check for anything suspicious in logs (tail /var/log/*.log, especially system.log),
  • reset your SMC, NVRAM & PRAM,
  • unload 3rd party kernel extensions (in single mode, probably you need to relocate them from /System/Library/Extensions, but if you didn't install any (like vboxdrv), better leave it, as it may get worse),
  • in single mode, verify your NVRAM variables sudo nvram -p and consider to run your kernel in different mode, for example:

    For more options, check: Boot argument options in OS X. When it work, don't forget to disable it.

  • consider using 3rd party recovery tools (e.g. recovery DVD from DiskWarrior),

  • consider reinstalling your OS X.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.