4

I have had this problem before, but I was able to hide the warning by creating the shortcut on my Desktop first, and then moving it into the toolbar. But now after being required to install Internet Explorer 11 for Visual Studio 2013, all my shortcuts need this permission. Why is this happening and how to fix it?

Edit: The problem persists; it breaks all my shortcuts in that toolbar once in a while. Today they were fine but then after two hours of absence I came back to the computer to find them broken again. What is happening here?

This is the toolbar:

enter image description here

This is what I get when I click Calculator:

enter image description here

Here is the Security tab of that shortcut:

enter image description here

  • If you right-click the shortcut and choose properties, where does the shortcut link to? Is it a local file or perhaps a file on the network? – LPChip May 20 '15 at 15:20
  • Go to folder C:\Users\{user}\Favorites\Links, right-click on Calculator.lnk, choose Properties, and post a screenshot of the Security tab. – harrymc Jun 23 '15 at 14:24
  • @harrymc, added screenshot. – Rookie Jun 23 '15 at 20:08
1
+100

From the masterful analysis of the problem by @Yorik, we can find a solution to the problem :

  • Open Control Panel -> Internet Options
  • Go to the tab Security
  • Click on the Internet zone
  • Click on Custom level...
  • Find Launching applications and unsafe files, and set it to Enable
  • Click OK

This will enable the download of executable files from the Internet, resulting in a Save dialog that one can still cancel.

This setting only allows to download files, but not to execute them. Downloaded files remain blocked and permission must be explicitly given by the user to execute them via the "Do you want to open this file" dialog.

In the case of the poster, as the calculator is a local file and no download is involved, the calculator will be executed. As it is already unblocked, that dialog will not appear and the calculator will be executed.

image

More info in this article.

| improve this answer | |
  • 1
    +1. Solves the problem but lowers security. Using a non-magic folder can avoid this, but there may be reasons the user needs to use "Links" – Yorik Jun 24 '15 at 14:25
  • @Twisty: It is default for this folder - read the answer by Yorik for explanation. Please justify your downvote and explain how is it very dangerous (it's off on my computer, since I often need to download products from the Internet, but I don't feel threatened). – harrymc Jun 24 '15 at 21:26
  • 1
    @Twisty: There is a confusion here, this setting allows to download files, but not to execute them. Downloaded files remain blocked and permission must be implicitly given by the user to execute. Do you really think that the user is dumb enough to click on a link that gets him a Save dialog, then stupidly click on Save, then inexplicably double-click on the file to execute, then finally ultra-stupidly allow its execution in the "Do you want to execute this file" dialog? Come on! Users are not that stupid. – harrymc Jun 25 '15 at 6:07
  • 1
    This setting does not turn off the "Do you want to execute this file" dialog for downloaded files, just for files that are already on the computer and are unblocked, such as the calculator. There is no real risk - this setting is just Microsoft protecting really clueless users, but is an over-kill for anyone with a minimum of knowledge. The poster here looks like he knows what he is doing. – harrymc Jun 25 '15 at 6:12
  • 1
    Its "sanity check" security. It merely prompts you to think. So "no" I don't think it is a big deal and why I +1 the answer as a potential solution. Personally, I never disable UAC or other such prompts because they are there for a good reason (however misguided some pros think the security approach is). If you don't need to use the "links" location for calculator and other local program shortcuts, then just make a special folder for your taksbar shortcuts like I suggested and avoid the need to adjust the setting. – Yorik Jun 26 '15 at 14:54
5

The "Links" toolbar in the OS is a magic folder that points to the IE favorites toolbar.

If you browse with windows explorer to "c:\users{username}\favorites" you will see a folder named "Favorites Bar". If you dive into that folder and then click on the blank space in the location area, the path you see is actually "C:\Users{username}\Favorites\Links" which is the same path we see in your security popup.

I was able to create a link to calc.exe on the taskbar toolbar (by dropping a shortcut into the folder in windows explorer) and then open it without any prompting, but when I launched IE and enabled the favorites bar inside that program, clicking on the link in IE resulted in a security prompt and then the taskbar toolbar link started prompting me even after I closed IE, and continues now after a reboot.

I believe that the Favorites bar is actually an "internet zone" and the question should really be framed as "why am I not prompted sometimes".

For a workaround, you can make make a folder called e.g. "quicklaunch" or whatever and then add that as a taskbar toolbar ("new toolbar", then point to the new folder), then hide the toolbar name. You can then back up/restore that folder when you reinstall or move to a new computer (provided the links are valid)

| improve this answer | |
  • If you are on a work domain, there may be a group policy refresh happening which alters behavior during the day, perhaps when you lock out your workstation or ... (?) – Yorik Jun 23 '15 at 21:06
  • -1: you can't simply create a different folder. The links folder behaves differently when attached to the task bar: it can open subfolders as popup, while other folders won't allow that. – Thomas Weller Mar 1 '17 at 11:55
1

You can disable the warning by right-clicking on the link, choosing Properties, and finding its target (probably calc.exe in your case), and then right-clicking on that file and clicking "Properties", and then clicking the "Unblock" button.

Example unblock button:

Example unblock button

Why it appears now where it didn't before, I'm not sure. It should only occur if you downloaded the file from the Internet. If you're confident it was after installing an update, you can try rolling back the update by using System Restore to go back to the Restore Point that was likely created before installing the update, to see if it reverts this behavior back. Then try installing the update again. It could've been a glitch in the install process, or a bug in the update.

| improve this answer | |
  • 2
    This feature is known as "Mark of the Web" (link references html files, but behavior with executables is similar) and intended as a security feature. This behavior is only expected on something you downloaded from the internet... if you're now getting it on random other executables (like the Windows Calculator) I'd be very suspicious of virus activity. – BowlesCR May 20 '15 at 16:11
  • Where is this "unblock" button? I cannot find it in properties. – Rookie May 20 '15 at 17:05
  • Okay i fixed it now: i created a shortcut on my desktop first, then i cut the shortcut to the toolbar. Silly, but it works. I have no clue how to make it work properly. – Rookie May 20 '15 at 17:09
  • 1
    Nonsense : Why would anyone ever need to unblock the calculator ? – harrymc Jun 23 '15 at 18:56
  • 1
    @harrymc Well, therein lies the question, doesn't it? Why does he? – Ben Richards Jun 23 '15 at 19:20
1

Based on the "Open File - Security Warning" message, look like it have the Zone.Identifier NTFS Alternate Data Streams (ADS) there. Normally IE will add this ADS when download file from Internet, not sure why it happened in your shortcuts too.

To remove it, get Windows Sysinternals utility Streams, go into that folder run below command to delete all ADS for all files. Add -s if you want to include subfolders.

streams -d *

Here is more details explanation on NTFS ADS.

| improve this answer | |
1

This was the way I got it to work, without lowering global security level, Windows 7 Home Premium:

ICACLS "%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch" /Setintegritylevel (OI)(CI)Medium

It sets all subitems in the Quick Launch bar to "medium". It applies to the items pinned to my task bar. Don't ask why it's under "internet explorer"!

| improve this answer | |
  • "Don't ask why ... " I note in my answer that it is because the folder is a Windows magic folder that points to the Internet Explorer favorites. and is in the "Internet Zone." You are setting that folder to medium security instead of maximum security – Yorik Dec 22 '15 at 22:23
  • Ah thanks! I didn't see that bit. But I wonder why on earth pinning a program to the task bar should have anything to do with "internet favourites"?? – Sanjay Manohar Dec 23 '15 at 1:38
  • IMHO C:\Users\{user}\Favorites\Links is the better folder. Use /T for subdirectories as well. – Thomas Weller Mar 1 '17 at 11:57
0

Windows 7 onward has a paranoia feature that alters Desktop permissions when it has trouble joining a domain. Somehow that must have been triggered on your computer (power failure, router down, whatever). Reset it back to normal (or Medium) using this command at a CMD command prompt with proper username:

ICACLS "C:\Users\<username>\Desktop" /Setintegritylevel (OI)(CI)M

If the above does not work, then create a new local user and see if this new user also has the same problem. If so, then you will have to edit the Group Policy Editor as local Administrator to fix this problem.

| improve this answer | |
  • Why should I apply this to the Desktop, when the favorites bar is affected? – Thomas Weller Mar 1 '17 at 11:56
0

What worked for me in Windows 10 was to lower the internet security level from Medium-High to Medium:

Lower internet security settings

After that my shortcuts totally stopped working and wouldn't open anything at all, so I returned the security level to Medium-High and the links would still not work so I deleted them created new ones and these worked fine with no warnings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.