2

I know this should be easy, but I'm having a hell of a time figuring out where the vmware tools cdrom is (for instance it's not /dev/cdrom) and so I can't figure out how to mount it. I'm on Kali Linux, using VMware player 7. The VM I'm doing this on is Metasploitable 2(ubuntu)

I go to Virtual Machine > Install VMware Tools... a little window comes up saying I should press install, then mount the cdrom in the guest vm, decompress the installer and run vmware-install.pl. However, having googled around for some time, I can't figure out where the cdrom is. Most tutorials say to do something akin to this:

mount /dev/cdrom /mnt/cdrom

Fine. Except there is no /dev/cdrom or indeed anything remotely similar inside /dev. So I get the error:

mount: special device /dev/cdrom does not exist

There is a ~/cdrom and a /media/cdrom and a /media/cdrom0 but all of these result in the error:

mount: /media/cdrom0 is not a block device

Which I think is due to me attempting to mount something that's not in /dev. Also, creating /dev/cdrom and attempting to mount results in the above error also.

I have checked and made sure that the vmware tools iso is in the virtual cd drive(it's connected to /usr/lib/vmware/isoimages/linux.iso on the host machine. This is done automatically by selecting Virtual Machine > Install VMware Tools... ). I am at a loss as to how to continue, and any help would be much appreciated.

  • you don't see it mounted when you run the command mount right? – Frank Thomas May 21 '15 at 16:25
  • @FrankThomas No, it's not there – Totem May 21 '15 at 16:36
  • Make sure the virtual cd of the guest is connected (if "connect at start" is not checked, it will not be connected automatically) – Dan May 21 '15 at 18:40
1

The answer was to mount /dev/sr0 instead of /dev/cdrom. So the following command worked:

sudo mount /dev/sr0 /mnt/cdrom

I had to create /mnt/cdrom with mkdir for this to work.

  • This also worked for me. Can you explain why this was the solution? Still trying to learn my way around Ubuntu. – Erutan409 Apr 20 '16 at 16:03
1

I had the same problem, but with vmware workstation 12 and ubuntu server. It WASN'T solved by typing sudo mount /dev/sr0 /mnt/cdrom because for whatever reason the iso was on a different drive.

The solution- after clicking on install/upgrade VMware Tools type

blkid -c /dev/null

The above command shows all mounted and unmounted drives. I saw /dev/sr1: LABEL=”VMware Tools” TYPE=”iso9660”

I used the above information to determine which drive to mount. Next type

sudo mkdir /mnt/cdrom
sudo mount /dev/sr1 /mnt/cdrom
ls /mnt/cdrom

You should see information similar to the picture below vmware-tools version

Use that information to determine which version you need, then (adjusting the version as appropriate) type

tar xzvf /mnt/cdrom/VMwareTools-10.0.6-3595377.tar.gz -C /tmp/
cd /tmp/vmware-tools-distrib/
sudo ./vmware-install.pl –d

and you are done. I hope this helps someone.

vmware after installation information

RESEARCH

blkid information

How to install vmware-tools from command line using ubuntu server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.