0

So the basic scenario is this. UserA creates a folder with a few subfolders and documents. UserB comes along and changes the permissions on the folder and subfolders so he can list folder contents and read folder (not modify or write). Everyone else, including SYSTEM and the owner, can only list folder contents. I know the owner should be able to override permissions on the folder but they can't even see the folder to change permissions. So UserB can't change the permissions because he doesn't have permission to do that and isn't the owner. And UserA can't even see the folder to do anything with it.

2

Edit the ownership of the parent folder (Security -> Advanced -> Owner -> Edit) and apply that to all subfolders.

enter image description here

after that's done, edit permissions to apply wanted permissions, then tell it to apply the permission to all subfolders before applying.

enter image description here

  • I tried from UserB's account and permission is denied. – codesmyth May 21 '15 at 19:04
  • If you didn't, do it form an account that has administrator permissions. Also, you need to take ownership first, including "Replace on subcontainers" option (I'll edit this into my answer). – Ƭᴇcʜιᴇ007 May 21 '15 at 19:08
  • I tried it from UserA and UserB's accounts (both have Administrator permissions). Neither one worked. UserA still isn't showing the folder at all. UserB is denied. Administrator's account has no permissions except list contents. I think part of the problem is UserA's account can't see the folder to make permission changes. – codesmyth May 21 '15 at 19:17
  • Are these folders on a local Windows machine, or are they on a network share? If they are on a remote computer, do these users have Administrator permissions on the computer the folders are located? When you try to change the ownership on the parent folder to one of the Administrator users in question, what is the actual error message you get at that point? – Ƭᴇcʜιᴇ007 May 21 '15 at 19:21
  • 1
    They are on a network share. The error is "An error occurred while applying security information to: S:\F... Access is denied." – codesmyth May 21 '15 at 19:26
0

Share permissions are not part of the effective permissions calculation. Access to shared folders can be denied through share permissions even when access is allowed through NTFS permissions.

When permissions have been assigned both to the shared resource and at the file system level, the more restrictive permission always applies.

The starting point must be to investigate the share permissions.

Performing the following procedure to do so might require you to elevate permissions through User Account Control.

There are two methods to set/amend permissions on a shared resource, depending on the resource type.

To use the File Sharing wizard to set permissions on a file or folder:

  1. Right-click the file or folder, and then click Share.

  2. Complete the File Sharing wizard to select the user and group to share the file or folder with and to set permissions on the file or folder for each user or group.

To use Windows Explorer to set permissions on a resource:

  1. Open Windows Explorer.

  2. Right-click the object, and click Share or Properties.

  3. Click the Sharing tab, and then click Advanced Sharing to set permissions.

You can use the File Sharing wizard to manage shared resources on both local and remote computers. With Windows Explorer and the command line, you can manage shared resources on your local computer only.

If you change permissions on special shared resources, such as ADMIN$, the default settings may be restored when the Server service is stopped and restarted or when the computer is restarted. Note that this does not apply to user-created shared resources whose share name ends in $.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.