0

When my Gnome Terminal running on Ubuntu 14.04 moves into fullscreen mode, I can see the bottom line wasted.

Everything is ok when in non-fullscreen. Tmux's status bar lies at the bottom of the terminal.

However, in fullscreen mode the bottom line keeps empty. Tmux's status bar cannot reach that line.

Why does Gnome reserve the bottom line? How can I configure Gnome Terminal to enable the bottom line? I didn't find the option in 'Profile Preference' setting.

My reputation is lower than 10 to post snapshot for the cases....

1

That sounds like a bug: gnome-terminal uses only scalable fonts, which should allow it to use the entire screen. It does not implement a hardware status line (which would be the usual reason for a reserved line).

If gnome-terminal were setting the fontsize without taking the screensize into account, this could cause it to (later in the computation) refuse to display on the unused part of the window.

More likely: characters have a given aspect ratio, and the underlying libraries are less flexible about rendering with altered aspect ratios than one might suppose. So gnome-terminal could be making a less-than-optimal choice about the character size, using less of the screen than you would like.

| improve this answer | |
  • Yeah, the last line seems to be an incomplete one... – xywang May 24 '15 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.