I have a system that has been running as a Linux box for the last few months. Originally, it's OS was Windows XP Media Center Edition.

Another computer failed on me, so I installed Windows XP Professional SP1 on the system the first system, The installation completed successfully, but when it came to the first boot, it hung at the Windows Logo.

Rebooting into safe mode revealed that it was consistently freezing after MUP.SYS was loaded. I reinstalled. Again the installation completed successfuly, again it froze during the first proper startup after MUP.SYS. I guessed my XP disc was broken, as it had been giving me trouble before.

So I tried again with another disc (XP Home SP2 this time as I no longer have the media center disc. The system was not powerful enough to run Vista, and my only Vista disc is a Dell disc anyway). Installation completed successfully, same problem occurs.

As a test, I reinstalled Ubuntu, and that installed, and ran perfectly.

The system in question is a Compaq Presario SR2000


  • Reseating all internal components does not help.
  • Running memtest86+ overnight says the RAM is ok.
  • Resetting to BIOS defaults doesn't help.

Google suggests updating the BIOS to the newest version. However, the only method provided to update the BIOS on this system is to run a Windows program. No Windows, no BIOS update. No BIOS update, no Windows.

Update 2

I transferred the RAM, Hard Drive, CD drive and firewire card to another old computer and installed and ran Windows successfully on that. I would still prefer to use the first system, as the the second system is quite small and tends to overheat. (This also rules out any of these components being at fault)

  • the motherboard is the only component that's left then, right? so it's either some incompatible BIOS setting causing the error or faulty hardware. – Molly7244 Jan 6 '10 at 12:36
  • Probably. Resetting to BIOS defaults doesn't help however. So it must be either the motherboard is faulty or the BIOS is borked. Weird Linux works and XP doesn't. – Macha Jan 6 '10 at 13:31
  • Did you also xfer the HDD data cables too, or use the cables in your second system? Just a thought. Also consider the drive controller, it's also a possibility. – invert Jan 7 '10 at 8:38
  • I used the same HDD cables in the second PC. – Macha Feb 13 '10 at 22:06

Mup.sys is not usually directly related to the problem as it is usually the last file to be loaded, it is the one visible.

This is most usually related to memory, but it can also be bad devices. I would start by disconnecting everything optional from the machine - have just keyboard, mouse (if you need it) monitor and power.

If you are still having problems, I would advise that you reseat all memory just in case there was any nocks or bumps and after this, (or before) run a full memory test using Memtest86+.

  • Open the case, reseat all addon cards, memory modules and connectors

  • Load the BIOS defaults

  • Run Memtest86+

  • Yep, Its probably memory related. Do at least 12 hours of the MEMtest86+ to make sure... – thegreyspot Jan 6 '10 at 0:26

I had exactly the same error two weeks ago, and turns out the HDD I used had bad sectors on it, it's worth a look if this is your problem as well.

You can try and fix the bad sectors; Boot a Win98 boot disk to get into a DOS command prompt and run:

chkdsk c: /f /v

See this article for more chkdsk options. Good luck!

  • there is that possibility, but chkdsk will not recover/relocate all data from bad sectors and thus not fix the problem. reinstalling windows doing a thorough format might help, though i wouldn't recommend to use a drive with bad sectors. – Molly7244 Jan 6 '10 at 11:58
  • You are right Molly, there is a /r 'recover' option, but chances are those files are lost; a backup comes in handy here! – invert Jan 7 '10 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.