1

I have recently bought a Windows 7 Ultimate K, and changed it's language pack and such to English. I have two languages (Korean and English) I use on my computer and whenever I press SHIFT+SPACE it changes it. This really bothers me because when I type I hold the shift and space button... A LOT (Changed language when writing "A LOT":P).This also makes gameplay on ANY game with a sprint+jump sequence VERY DIFFICULT. Any help?

marked as duplicate by Karan, fixer1234, mdpc, Kevin Panko, Nifle Jun 7 '15 at 13:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1
  • To access the settings for the language bar, you can either

    1. Go to Control Panel -> Region and Language -> Keyboards and Languages, then click Change Keyboards

    2. Click on the drop-down menu at the bottom right of the language bar and choose settings.

  • Once you have the settings open, go to the Advanced Key Settings tab.

  • In the section Hot keys for input languages, choose the action that has Shift+Space assigned as its key sequence (probably Between input languages). Click Change Key Sequence to change the hotkey.
  • You can either choose a new hotkey or disable hotkey switching by choosing Not assigned.
  • There are a limited number of possibilities allowed for hotkeys. If none of the choices for Between input languages hotkeys suit you, you could also disable the switching hotkey and assign individual hotkeys to each language instead (using the entries To English and To Korean). There are more possibilities allowed for these hotkeys (at least on the version of Windows 7 on my laptop).

Update

Ah, okay. I noticed that the hotkey Shift+Space wasn't available to me, but I thought it might be just a different version of Windows 7.

I wonder if you only have one input method installed and the Shift+Space hotkey is defined within it to change the character set. Okay...

  • On the Text Services and Input Languages window (that you get when you click Change Keyboards), look under Installed services.

    • Is there only one entry? Is it Korean?
    • It should have a subheading Keyboard beneath it. Under that should be a subentry listing an IDE. What does it say?
    • Right click the IME and choose properties and look around. Do you see the hotkey?
  • When I go to hot keys for input languages, everything is disabled. When I go see to if it's a glitch, there is no setting for Shit+Space, just ctrl+shift, left alt+shift and grave accent (). – Anonymus May 23 '15 at 8:23
  • Ah, okay. I noticed that hotkey wasn't listed in my settings, but I thought it might be just a different version of Windows 7. I've updated my answer, try what it says at the end. – pyrocrasty May 23 '15 at 9:06
  • Never mind! I messed with it after it didn't show any hotkey settings and noticed there were 3 Korean settings. I picked the best one and realized that the problem was fixed! Thanks for the help! – Anonymus May 23 '15 at 12:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.