0

I replaced the two cards of memory, of 2Gb each, with two cards of 4Gb each (Samsung M395T5160QZ4 - CF7 1412).
(I have ubuntu so it should be able to use memory above 4Gb.) My motherboard is GA-MA78LM-S2H.
When the computer loads the BIOS says I only have ~4Gb. (I expected 8Gb) Is there something I can do (maybe in the bios) to enable all the memory?

  • OS won't affect BIOS – barlop May 24 '15 at 11:16
  • do u have ram from another system to test with – barlop May 24 '15 at 11:18
  • and try with one stick then the other stick, as maybe you have one faulty stick – barlop May 24 '15 at 11:19
  • I did, they both worked separately. – kroiz May 24 '15 at 11:28
  • Did you solve it? And if so, what solved it? – barlop May 24 '15 at 15:50
1

Operating System

You will need to be more specific on the type and make of the memory, the bit level of the OS and what is telling you there is only 4GB available. Is the OS showing 4GB or is it the BIOS? If the BIOS is showing 8GB, but the OS is showing 4GB, that's likely a 32 bit OS issue.

32 bit operating systems max out at 4GB regardless of how much you place into the motherboard. Though, some 32 bit Linux systems with the correct CPU setup and the correct kernel can expand the 4GB to 64GB with the PAE bit. To actually enable memory above 4GB on an operating system, you would need to upgrade the OS to a 64 bit version. Or, alternatively, find a Linux 32 bit version that supports PAE.

BIOS

If your BIOS is not showing 8GB, then you may have the wrong type of memory inserted, one of the sticks may be faulty or not fully inserted, interleave is set up incorrectly, the motherboard requires a specific jumper setting or the BIOS needs to be told about the new memory. Though, with most recent motherboards, any memory inserted should automatically be detected and recognized.

I would also review Gigabyte's supported memory list just to be sure your memory is supported for this motherboard model.

Since it has been determined that the BIOS is not seeing the 8GB, I'd look at the memory itself. I've reviewed the memory stick model M395T5160QZ4-CF7 and it is not in the list of supported ram sticks list by Gigabyte for this MB. In theory, it is PC2-6400 DDR2-800 ECC RAM and it seems like it should work. The Samsung memory stick that is listed is M378T5263AZ3-CF7. Though, there are also plenty of other brands to choose. Not all memory sticks are created equal. This is the reason MB manufacturers create lists of tested memory and publish them. If you can return this memory and replace it with memory in the supported memory list, you may be better off in the long run. I wouldn't trust using an unsupported memory stick in my computer even if it seems it should work.

Added by barlop

The aspect of this answer that the OP considers to have solved it, is the mention of the

Memory Support List here

http://download.gigabyte.eu/FileList/Memory/mb_memory_ga-ma78lm-s2h.pdf

Which does not include his model of RAM so to rectify that, he could get modules that are listed.

| improve this answer | |
  • It is the BIOS that is telling me that I have 4GB. – kroiz May 24 '15 at 11:08
  • Regarding the PAE, Actually, on Ubuntu, you don't need any special setup, the kernel (since ubuntu 12.04) supports PAE out of the box. So once you add memory it will just work. – kroiz May 24 '15 at 11:11
  • I would recommend opening the computer up and inserting one stick in a slot at a time (assuming the motherboard supports this). Then, power on and test each stick separately. This way you can determine if both sticks are functioning. – Commorancy May 24 '15 at 11:17
  • As for PAE, Ubuntu doesn't always enable it depending on processor make. Certain Pentium and Celeron processors do not automatically enable PAE. Because your motherboard appears to based on AMD Athlon or Phenom, this shouldn't be an issue. – Commorancy May 24 '15 at 11:32
2

I imagine you are talking about Windows not seeing 8GB, not the BIOS. If it is the BIOS, skip a bit further on.

When you are running a 32 bit operating system (in normal mode with a normal kernel), it can only access a 32-bit address register, which are a total of 232 addresses or guess what 4 GiB of RAM.

With 64 bit, on a technical scale, you can access about 16 EiBs (18.1 exabytes) of RAM. Do note that practically this is impossible and also chipset/operating system limits are MUCH lower.

You need to download and reinstall a version of Ubuntu with a 64 bit kernel and 64 bit support.

If you do not see all your RAM in BIOS

It is also possible that in your BIOS, it is not enabled to access 64 bit memory. This was common on older motherboards with older BIOS. Update the BIOS just in case.

If after updating the BIOS, you do not see all 8GB of RAM

  • Check that you actually physically installed the RAM correctly
  • You might want to check your manual for a option for access all of your memory. Sadly there is no universal term. Microsoft calls it "memory remapping" or "memory extension".
  • After this, if you still do not see all of the RAM, is the RAM you installed specifically listed as being compatible in the manual with the motherboard? Sadly, some motherboards are REALLY picky and just do not want to play nice with say Crucial memory but do play nice with Kingston memory. Again, this is something from the older motherboards and less common nowadays.
| improve this answer | |
  • +1 re flashing BIOS. I'm not sure that it'd do/fix it but it's a good idea worth doing just in case it does. – barlop May 24 '15 at 11:17
  • I posted the exact same thing before the answer that is selected as "Correct" and mines isn't marked. Amazing... – riahc3 May 24 '15 at 12:31
  • we till have no idea what, if anything, solved it for him – barlop May 24 '15 at 15:49
  • see my note on the accepted answer, as to what the OP considers to have solved it – barlop May 25 '15 at 10:33
  • I suggested that if his RAM still does not work he should check the manual for comparability... – riahc3 May 25 '15 at 10:49
1

You shouldn't have to do anything in the BIOS etc—it should just work.

And your board does support up to 8GB of RAM.

Try removing and reseating the memory, to make sure it has connected properly.

If that doesn't help, and the memory is of the correct type, one of the 4GB modules you have installed may be defective. Try with one module at a time, to establish whether they both work.

| improve this answer | |
  • I am confused, others in this thread claims that this could be BIOS related. I tested each memory module by itself and each of them worked fine. – kroiz May 24 '15 at 11:36
  • 1
    They are right in principle, but your motherboard was first available as recently as 2010 so I'm guessing the BIOS isn't the issue. But a BIOS update is certainly a good idea if the other checks haven't helped. – Reg Edit May 24 '15 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.