2

EDIT: I'm pretty sure it's the video driver's fault because:

  • save mode reboots/shuts down fine
  • with uninstalled drivers shuts down fine.

The problem: AMD drivers from their website and drivers that Windows get via updating driver from Device Manager OR Windows update are pretty much the same. No matter which of these options I choose, the freezing begins after driver installation. I tried using older drivers but they update instantly, of course.

Since HP website provides drivers (for my laptop model) only for Windows 7, I'm lead to believe this quite capable laptop is not supported to run Windows 8/8.1 which I find staggering and absurd. I'd gladly test older AMD drivers if only I can find the way for Windows update to not update them upon installaion. That or completely switch to Lubuntu. FWIW, the Windows 7 DVD did not come with the laptop purchase, bought the Windows 8 upon its release and did a clean install.


I'll try to be as thorough as possible, if you think I missed something, let me know and I'll edit this post as soon as I can (unless you think reply is a more viable option).

OS & machine: Windows 8.1 x64 on 4yr old HP Pavilion dv6 (dualboot with freshly installed Lubuntu 15.04 x64), i7 quad-core, 500GB HDD, 6GB RAM, dual display with full HD LG monitor via HDMI, GPU ATI Radeon Mobility 5000 series. Battery is kinda crap since it'll hold about 20min altogether therefore I'm mostly just plugged on AC. In 3/4 of cases I'm connected to LAN, wifi works but only use it when I'm not connected to LAN cable.

Symptoms: system freezes about 8 seconds into shut down or restart process, forcing me to hard reset it every single time. System logs show:

  1. Kernel-power, ID 41, category 63;
  2. Kernel-power, ID 142, category 173.

... aka "the system didn't shut down properly" - because I had to hard reset it - because it froze. I usually just put it to sleep instead of shut down, after a number of days (3-5), the system would BSOD on me. In rare cases (fast startup and hibernation were enabled back then) when I did shut it down, it shut down properly in about 50% of cases.

Already tried: hibernation is disabled, fast startup is disabled (it does appear to happen a bit(!) less frequently if fast startup's enabled but then I can't properly access NTFS partitions from Lubuntu), ran sfc /scannow and it returned with "unable to repair"

  • A) utc.app.json,
  • B) telemetry.ASM-WindowsDefault.json (tried SFCFIX for this one, said it's been successful, didn't try sfc scan again afterwards) and
  • C) AMD64/CNBJ2530.DPB.

Scanned HDD: ok, scanned RAM: ok, device installed & drivers updated, all Windows updates installed, virus check with Defender found nothing. Tried tracking the shutdown process with some command-line thing (I forgot what it was but it's from Microsoft, part of some SDK), after the hard reset it said nothing could be tracked. It gave me one blank log (shutdown_BASE+LATENCY+DISPATCHER+FILE_IO+FILENAME_1_km_premerge.etl) and one that had a few lines (shutdown_BASE+LATENCY+DISPATCHER+FILE_IO+FILENAME_1_um_premerge.etl).

Other people with similar problem: some said it was their PSU but since Lubuntu shuts down and restarts with no problem, I assume the problem is on Windows' side. Some said they disabled ATI's sound (which of course cuts sound to my monitor) - tried & no luck. Some people just gave up.

Also 1: sometimes the system would randomly BSOD on me, in the past it's been something USB related. I run a mouse via USB but that's about it.

Also 2: I update Windows on a regular basis. Every couple of weeks or so I get 10+ updates, they install, upon first restart the system freezes (every single time!), takes about 15 minutes of install-restart cycles on a blue background (that happen before the whole login screen). When all is done, the login screen appears.

History: got Windows 7 with this machine, soon upgraded to 8 and later to 8.1. The freezing problem's been more obvious in the later version.

I'll try: to shutdown/restart with USB mouse unplugged, with no second monitor, LAN cable out and on battery. will report how it went.

I hope you can make something of this mess because I can't :/ Thanks for your help in advance.

  • Most common culprit for this kind of thing seems to be graphics card drivers. That could be why you are only seeing the problem on Windows. Can you track down some different versions of the drivers for your card and see if that helps? – Julian Knight May 24 '15 at 20:36
  • You reminded me of this situation: some time ago (a few months, I suppose) after a certain Windows update pack -not sure which one- Catalyst thing disappeared from the system and video drivers for AMD card were replaced with the Microsoft ones from the update. I've tried to replace drivers with AMD ones multiple times but gave up eventually. – derpoholic May 24 '15 at 21:27
  • Ah. Might be time to try again then. – Julian Knight May 25 '15 at 12:23
  • Tried it again, no success. Post updated. Thanks for your answers, by the way. – derpoholic May 26 '15 at 7:04
0

Have you resolved this problem? I have the exact same problem.

Already tried:

  1. Clean Windows 8.1 install.
  2. Drivers updated.
  3. Windows updated.
  4. Bios updated.
  5. Other adapter.
  6. Other battery.
  7. Switched on/off Fast boot.
  8. Ram test => passed.
  9. Seagate HDD test => passed.
  10. ODD => passed (even burned a dvd with it)

I thínk I have a workaround, but its not stable.

  1. Fast startup "enabled" works, when system shuts down. Restart gives power kernel 142, category 173.
  2. Fast startup "disabled" works, when system restarts. Shutdown gives power kernel 142, category 173.

Important is, that it has to meet these conditions. Still looking for permanent solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.