24

I am using pycharm and its memory shown at bottom right corner is 750M. I could not find any setting where I can increase that. Where do I increase that memory. I am using version 3.4.

I searched a lot but could not find from Google as well

1
19

Under the /bin directory of your pycharm installation, there is a file pycharm.vmoptions. You can use this to customize the options that are passed to the JVM. The maximum heap size should be given by

-Xmx750m

There is a list of memory options in this blog post

3
33
  1. Help->Find Action->(type "VM Options")->(Click)"Edit Custom VM Options"
  2. Pycharm (2016.2) will open the appropriate vmoptions file (pycharm.vmoptions or pycharm64.options) in the editor before you.
  3. Change -Xmx750m to -Xmx1024m, or whatever size you want. Save it.
  4. Restart Pycharm (File->Exit etc.)

Official 'Increasing memory heap' documentation is here

3
  • 1
    easy and clean solution – Mehedi Aug 9 '17 at 3:54
  • hi! what if i want to give more than 1024? what other # can i use? or... can you let me know waht this number is called? so i can google it :/ thank you! – alwaysaskingquestions Feb 23 '18 at 19:00
  • 1
    @alwaysaskingquestions You can change the number to whatever amount of memory you decide to dedicate to it. If you click on the link you'll see that it's called the "Maximum heap size". – John Mee Feb 26 '18 at 2:37
0

Rather than manually searching for the right files, you can (at least in PyCharm 5) now just search for or navigate to "Edit Custom VM Options" and it will create and open a default vmoptions file for you, as described in https://www.jetbrains.com/pycharm/help/tuning-pycharm.html. Then,

To increase PyCharm heap size, ... modify the -Xmx setting.

EDIT: I don't know why, but this process created a pycharm64.vmoptions file for me and that didn't actually change the heap size (as indicated in the bottom right "Show memory indicator"). I actually had to rename that file to pycharm.vmoptions for it to work.

0

Go to /JetBrains/PyCharm 5.0.1/bin

There will be two files in case of 64bit version. pycharm.vmoptions and pycharm64.vmoptions.

Increase the Heap and Perm Size

-Xms256m

-Xmx1024m

-XX:MaxPermSize=512m

Note: You can increase it according to your system configuration. So do it wisely: if PyCharm doesn't open for you, it means that you over-specified the memory. I thought it wasn't working for me because of a pending restart, but wasn't working after restart either. Just open the 'vmoptions' files and bring down the values iteratively until PyCharm launches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.