1

I'm using Kali Linux amd64 and installed Google Chrome stable release from the official Google Chrome site but it is not launching nor showing any errors

i have tried launching it from the command line but it won't give any output.

System information:

  • Intel Core i3 64bit
  • 4 GB Ram

What I have tried:

  • reinstalled many times no luck
  • removed pepper-flash no luck
6

Create standard user (root is default) and run it with him. If you want other solutions please use google. There are many but this is the simplest.

EDIT (as root):

  1. cd /opt/google/chrome

  2. Launching chrome simply will not work because in Kali linux we are the root user, chrome wants us to be another user. So launch it like this First make a directory for the chrome user storage mkdir /root/chrome

    Then start it like this: ./chrome --user-data-dir /root/chrome &

    The & so that we can continue using the shell while chrome is open.

  3. Anyhow close chrome and lets setup the shortcuts and alias. By now /opt/google/chrome is not on your PATH so just typing chrome from anywhere wont launch it. Easy fix set an alias or a symlink.

    First though lets make a start script for step 8 to always happen

    cd /opt/google/chrome touch startchrome.sh chmod +x startchrome.sh vim startchrome.sh

  4. In the script just put this:

    /opt/google/chrome --user-data-dir /root/chrome &

  5. Now make the alias - but we wont go that way because we will also need to make that permanent in /root/.bashrc and thats a bigger hassle then the next symlink method:

    alias chrome=/opt/google/chrome/startchrome.sh

    Or make the symlink:

    ln -s /opt/google/chrome/startchrome.sh /usr/local/bin/chrome

  6. Now to make the desktop shortcut, this app comes with Kali linux but double check

    apt-get install gnome-panel gnome-desktop-item-edit /root/Desktop/ --create-new

  7. Now Leave the type as Application and set the Name to "Chrome" and the Command type out or browse to /opt/google/chrome/startchrome.sh and hit OK

Source

  • but i want to run this as root user.i had it working before the update with --user-data-dir but now after the update it is not working at all – L0rd C0mmand3r May 25 '15 at 13:27
1
  1. Open google-chrome script using the following command:

    nano /opt/google/chrome/google-chrome

  2. At the end of the file, you will see something like this:

    exec -a "$0" "$HERE/chrome" "$@"

Just add --no-sandbox at the end of line. Make it look like below:

exec -a "$0" "$HERE/chrome" "$@" --no-sandbox

This worked for me with Kali 4.19.0 (2019-06-20) version.

0

I faced the same problem as I am a new to Kali Linux.

I followed the following steps to run applications as low privileged (non-root) user as some are recommended to run as low privileged (non-root) user for safety reasons, e.g. browsers and editors etc.

  1. Create a low privileged user account.

  2. Run command service ssh restart.

  3. Run command ssh nonrootuser@rootuser -X Here nonrootuser is your low privileged username and rootuser is your root user name . After that it is going to ask your low privileged user account password.

  4. Next command to run application. For e.g. in my case google-chrome to run the Chrome browser and now you run Chrome as non root user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.