37

Today I got this error when trying to access local domains specified in apache httpd-vhosts.conf. It happened for the 1st time with a .dev domain, so it seemed plausible that in light of recent news Goggle finally got it.

However, I tried with other domain names (eg. .abb or .loc) and the error persists. I' m working with UniServerZ on Windows7 and Chrome explains the "ERR_ICANN_NAME_COLLISION" error roughly as "this website uses new top level domain name. Contact your network administrator if it used to work". It indeed used to work with .dev domains.

Now, trying to google ERR_ICANN_NAME_COLLISION brings very few results and I have no network administrator to contact. :-)

The question is: is this me and possibly my hosts/vhosts settings or the world's fault? What local domain names should be good now to use for a local dev server?

8
  • 1
    Take a look to this resource: icann.org/resources/pages/name-collision-2013-12-06-en – mvillar May 25 '15 at 10:56
  • If you need a local TLD domain name, maybe use .local or .localdomain... IIRC at least one of those two are reserved for local use and will not be issued to any registrar anytime soon (as is the case with .invalid for invalid TLD examples, or example.com/.net for domain examples). – Arc May 25 '15 at 13:03
  • 2
    @Archimedix .local may be problematic as well: support.apple.com/en-us/HT204684 – Hagen von Eitzen May 25 '15 at 13:33
  • 1
    Do you have the domain name correctly listed in your hosts file? I got this error until I added it. – Simon East May 27 '15 at 0:54
  • 2
    Per RFC 2608, Section 2, .test, .example, .invalid and .localhost are the only TLDs guaranteed to never be allocated. tools.ietf.org/html/rfc2606#section-2 – Rodrigo M Sep 21 '17 at 15:51
18

The pseudo domain name(s) you are using are being registered as a new top level domain.

The DNS returns 127.0.53.53 which is a signal that this TLD is being registered by someone. Chrome versions from M43 have a this new way of relaying the error message to the user.

Use a domain name you own. Possibly using the full name like "localhost.dev.$yourdomain" could help you here depending on your setup.

6
  • Ok, I get it. Can I just make up a subdomain of a domain that I use for my personal website and put it in vhosts file or 1. do I need to buy one specifically for local use 2. should I set up anything besides the vhosts entry? – konrad May 25 '15 at 12:21
  • Just vhost entries alone does not suffice. You also need to setup matching DNS records. In case of linux it can be /etc/hosts or if you want other to be able to use it you need to register a domain and setup matching A records. – cstamas May 25 '15 at 12:42
  • Nah, it's for personal use only. So redirecting a subdomain of any existing domain under my control to localhost in hosts file + entry in vhosts to direct the subdomain to a local directory should be enough? – konrad May 25 '15 at 17:01
  • @konrad with /etc/hosts the domain does not even have to be under your control. – cstamas May 25 '15 at 17:19
  • /etc/hosts entries for a TLD you don't own are still a bad idea due to DNS leakage. A hostname typo will result in the real DNS servers for your "appropriated" domain being queried. From there what happens is anyone's guess; NXDOMAIN response if your luck continues, or wildcard DNS responses redirecting browsers to malware sites if you're not. If you are going to do this, make sure to edit all of your /etc/resolv.conf files to remove the domain that you don't own from the search path. – Andrew B May 25 '15 at 17:25
2

It appears that Google wants to use .dev only for internal puposes. Under that assumption it seems to be safe to host a "fake" dev zone on your internal DNS server

2
  • 8
    Do you mean it's possible to circumvent the error somehow with correct local settings? What should I set up for this? – konrad May 25 '15 at 16:55
  • Assuming you already have a private DNS server, look at its documentation for how to set up a "split horizon". – tripleee Mar 16 '17 at 11:47
2

ICANN has released new public gTLD-s, such as .dev. You can either add the local address to your C:\\Windows\System32\Drivers\etc\hosts file or change the site's address in your web server config file.

2

Use example.local instead of example.dev and it works for me.

1
  • 1
    This is a very good workaround. – dsignr Sep 10 '17 at 10:55
0

I got the same issue and I fixed when stop using more than 9 domains.

You can check if your host file (C:\Windows\System32\drivers\etc\hosts) have more than 9 domains

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.