If you take a screenshot with ++4 the file is saved as a .png to the desktop, but the extension is hidden. You need to open the Info dialog and untick "Hide extension" if you want to show the extension.

Is it possible to force it always to show extensions for screenshots?

I know it's possible to set Finder to always show ALL extensions, but I don't want to do that.


I don't think it's settable per app, only per file or globally - unless the app itself includes that functionality, like TextEdit etc.

There is no option within Grab itself - see The Complete Guide to Mac OS X Screenshots

The extension is always there, btw, merely hidden. If you copy to a text file, email, or another computer running Windows etc, the extension will reappear.

| improve this answer | |
  • Grab does not handle screenshots taken by the global shortcuts. Grab is com.apple.grab. Global Screenshots are handled by com.apple.screencapture as part of the SystemUIServer – cde Oct 6 '15 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.