0

I have a (wired) network consisting of two Windows 7 (x86) PCs, a HP network printer, and a gigabit network switch. There's no router or DCHP, so they all have fixed IPs in the 192.168.0.xxx region. There's very little chance of any other devices being added to this network and there will never be internet access.

One of the computers is frequently used to remote desktop in to the other. Files are transferred by a shared folder in both directions from both machines. Both machines belong to the same homegroup.

The problem is this: When either computer is rebooted, they do not recognise the network, and designate it as "public". They won't share folders or accept incoming remote desktop requests from this public network. Is there a way to either make all networks default to "Home", or a script (powershell/cmd both acceptable) run on startup/network connection to make the network tagged as home?

2

As the network has no name nor gateway, Windows can't memorize it, I guess. You may want to allow file sharing when being in a "public" network (if the computers can't access Internet that's not a problem). Some documentation about it: http://www.howtogeek.com/school/windows-network-sharing/lesson3/all/

  • That sounds like a potential solution. – CMaster May 26 '15 at 9:44
0

Have u tried to switch off 1 computer, than change settings in other they to become home network. And after that devices should remember this combination.

  • They don't remember the network. Also at some points, all devices on the network will have to be powered down. – CMaster May 26 '15 at 9:44
  • I would recommend then, to use router instead of switch, coz it can create network and other devices will join it. – A. Shulev May 26 '15 at 11:01
  • This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – DavidPostill May 31 '15 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.