Consumer radios, CD players, and car stereos often have a USB port, to play mp3's from a FAT32-formatted USB stick. However, some models don't just read files, they also corrupt files. How can such corruption be avoided or mitigated?

Examples of such misbehaving devices include my own Teac CD-P650, which on some USB sticks reproducibly leaves many directories empty (the missing mp3's move to /FOUND.000, after a Windows chkdsk), and a Duronic RCD99W boombox (from a forum post, lacking any details).

Some thumbdrives survive unscathed. On other thumbdrives, which folders get erased has no pattern. They aren't the largest ones (by number of bytes or minutes per file or per folder, or number of folders per file (max 99)), nor are they the first in alphabetical order.

Write-protecting files doesn't solve the problem: directories still get emptied. (Anyways, in FAT32 that's iffy: How to write protect a USB key?). Mechanically write-protecting the entire USB stick yields the same result. In both cases, audio still plays, so the player isn't upset about this hypothetical thwarting of writing temporary data. (Few USB sticks nowadays have a mechanical switch; I faked that with a write-protected SD card in a USB card reader.)

How might one even troubleshoot this? Where to begin? Disassemble the device to learn its USB chipset? What if the chipset is just a microcontroller bit-banging two pins?

  • Questions about electronic devices, media players, cell phones or smart phones are off-topic (except when they interface with a computer). See On Topic. – DavidPostill May 26 '15 at 16:43
  • Besides not using the functionality of those devices you know corrupt the filesystem of a FAT32 formatted disk, which likely means, they more then likely don't actually support FAT32 in the first place you don't have a lot of options. – Ramhound May 26 '15 at 16:46
  • Off topic: I found no closer match on StackExchange than superuser. But I'm open to recommendations. – Camille Goudeseune May 26 '15 at 16:53
  • 1
    With a large subsample of backup files or a large number of copies of a single duplicated file: Try renaming all the files with short sequential numbers; Try clearing the ID3 tags on all the files. You can use a tool like mp3tag to batch the whole thing pretty easily. This is just as a test: you can eliminate illegal characters and/or uncaught exceptions based on tags/filenames in the firmware as a cause. – Yorik May 26 '15 at 21:13
  • 1
    Have you tried ones with a hardware switch? You already mentioned it, without the result. It may fail to run as the device couldn't write its temp data but may NOT fail. You can still buy them for inexpensive price. eg. ebay.com/bhp/write-protect – Scott Rhee May 28 '15 at 0:44

Brute force: put a USB sniffer between the USB stick and the player, to directly observe how the player corrupts the FAT32 filesystem. At $400 retail, or many hours soldering together the open-source one, I'm not prepared to get one just to solve this. But others may like this approach.


The fault may lie in the USB stick itself. From one PC I copied a directory of a few dozen 1GB files to the USB stick, carried it to a second PC, plugged it in, and saw only the empty directory, without the files. The same symptom as the CD player, but without using the CD player. I'll retry this with other USB sticks from the same batch. If the fault recurs, then this is the likely answer.

Edit: faulty USB stick. After hearing audio glitches in the non-vanished mp3 files, I compared them to the originals with https://superuser.com/a/125399/221663. About 15% contained a 1024-byte block with a few dozen flipped bits. A very few files had more than one such block. I can only presume that similar corruption is what empties some directories.

A more expensive USB stick has not shown this fault after several attempts, while the original ones showed the fault every time.

  • Follow up thought: if you are write protecting your media in hardware and still running into this issue, and also experiencing this on a variety of different players, maybe the common factor is your computer. make sure you're safely removing your usb devices. – Wug Feb 6 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.