6

I've configured the following settings in my local security policy:

  • Interactive logon: Message text for users attempting to log on
  • Interactive logon: Message title for users attempting to log on

However, the system still does not display the login text.

I've also tried forcing the use of Ctrl+Alt+Del, with the above settings also configured, and that didn't work either.

Is there another setting, or a different area where this should be configured, that I'm missing for Windows 8?

All affected systems are using Windows 8.1 Pro, and are not currently joined to a domain.

Modifying the Lock Screen image is not an acceptable option – solutions must effectively emulate (or, preferably, enable) the normally expected effects of the policies listed above.

  • Note: Everywhere I've come across an online article on how to do this, they're just referencing the two "Interactive logon" settings I've already applied. – Iszi May 27 '15 at 19:03
  • Post your gpresult as HTML on pastebin. – Arthur Kay Jun 1 '15 at 17:05
  • Funny question : Do you have an account password? – harrymc Jun 1 '15 at 17:41
  • Not sure why it's funny, but yes - the accounts do have passwords. – Iszi Jun 1 '15 at 17:43
  • Was Windows 8 a clean install, or an update to Windows 7? – harrymc Jun 1 '15 at 18:11
5
+100

Solution :

Edit registry to :

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"LegalNoticeText"="Warning this is my message"
"LegalNoticeCaption"="My caption"
"DisableCAD"=dword:00000001

DisableCAD may not be needed

Infos & Debug :

  • Check your different value under :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  • GPO populates the registry under different keys :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\ legalnoticecaption legalnoticetext

  • GPEDIT.MSC Settings :

    Navigate through Local Computer Policy \Computer Configuration \Windows Settings \Local Policies\Security Options On the right pane window find INTERACTIVE LOGIN: Message text for users attempting to log on type your warning away in that box.

  • Reboot related issue 1 :

    gpupdate has been known to clear up policy related issues

    gpupdate /force

  • Reboot related issue 2 :

    Force reboot the system "shutdown /s /t 0" then turn on

Links :

Deeper info about LegalNoticeText

Carriage Return

Similar issue on TechNet

Detailed process

Captures :

Capture 1

Capture 2

Capture 3

Capture 4

0

For me it worked after setting the "Interactive logon: Do not require CTRL+ALT+DEL" group policy to Disabled.

0

Found possible solution from link:

  1. Press Windows + R to display Run command.

  2. On the Run command Type Regedit.

  3. Browse to: HKEY_LOCAL_MACHINE->SOFTWARE->Microsoft->WindowsNT->CurrentVersion->Winlogon

  4. From there Set Value of Legal NoticeText and LegalNoticeCaption to 1.

  5. Close The window.

  6. Next, go to Run command, By pressing Windows + R Key.

  7. Type Gpedit.msc

  8. Navigate through Local Computer Policy->ComputerConfiguration->Windows Settings->Local Policies->Security Options

  9. In the right pane window find INTERACTIVE LOGIN: Message text for users attempting to log on type your warning away in that box.**

  10. Click on it Type your Msg,Save and Exit, Then Reboot Your PC, You Will find Your message Before Login Screen.

Source.

  • 1
    How is this answer different from intika's answer? I blame the editor for making the link less noticeable, the reason this answer seems like it was copied from a website, is because it was. Sadly it appears the sole purpose of this answer is to advertise that website. – Ramhound Jul 7 '15 at 15:11
0

Using gpupdate or gpupdate /force commands in Command Prompt and restarting the machine will apply the group policy successfully. In some cases, this is what will be needed in order to make the policy update.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.