2

Noob question: (I don't know if this is the same for everything as it is for SASS), but after typing sass --watch sass:css it says Sass is watching for changes. Press Ctrl-C to stop., as expected, which is nice and fine, except the command line won't let me type anything after that. (I also wish to type sass --style compressed sass:css) I've tried Tab and Enter, etc., but it stays on a thick, underlined cursor similar to the one when you press Insert. I'm a total command line noob, just started using SASS today. Any help?

1

Have you tried:

sass --style compressed --watch sass:css

?

Both --style compressed and --watch are options that can be passed into sass. Depending on the program, most options that start with - or -- or / don't care about the order of the options. I expect the following to also be valid:

sass --watch --style compressed sass:css
  • That works! Thanks. :) For those reading in the future, just a small note, it should be compressed, not compress. – Jacedc May 27 '15 at 22:52
  • 1
    @Jacedc Thanks, I updated my answer! You should also be able to edit your original question (which is where I copied compress from ;) ) – Darth Android May 27 '15 at 22:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.