3

How can I configure Windows to use keys on the right side of the keyboard to switch input languages? I'd prefer to use right Alt + Shift, or even better, both left and right pairs of Alt + Shift.

I did this in my previous OS installation but can't remember how I did it. Maybe I need to use third-party software?

2

You can achieve this with autohotkey software.

Step 1 - Install Software

Step 2 - Create a script

  • Right click anywhere on your desktop, hover on "new", click "Text Document"
  • Open the document and add this text to it
    RALT::LALT

  • Save the document and then rename it to something with .ahk
    e.g.
    languageInput.ahk

  • Double click the script to run it

Now the right alt should behave the same as the left alt.
You can also add this script to the startup folder to make it run every time windows starts.

Step 3 - Copy and Paste into Startup folder

  • Right click on the script and select copy or cut
  • Paste it into the following location C:\Users\*yourUserName*\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
| improve this answer | |
  • No problem, glad i could help. – Cosco Tech May 30 '15 at 17:07
  • But when I'm connected to remote host via RDP, and press right alt the keystroke are sent two times - one as left alt and another one as right alt. When I use right pair alt + shift to switch language, remote host receives simultaneously left alt + right alt + shift, switches language and opens menu. When I press right alt to leave menu it receives two alts again and... returns back to menu. It is enraging me. So, have to find another way... – Jury Jun 23 '15 at 22:37
0

Go to "Control Panel"
Click "Clock, Language, and Region"
Click "Change Keyboards or Other Input Methods"
Click "Change Keyboards..." button
Go to "Advanced Key Settings" tab
Here you can change the key stroke options between input languages or for a specific language.
enter image description here

| improve this answer | |
  • There is no choice to use right Alt + Shift. It doesn't help me. Unfortunately. I was in this menu... – Jury May 29 '15 at 19:25
  • 1
    You could change to ctrl + shift which would work on the right side. – Cosco Tech May 29 '15 at 19:28
  • Omg, all my life I'm using Alt. It is so easy, why I can't use my fave combination? – Jury May 29 '15 at 19:38
  • Probably for the same reason that Windows can't spit out monoaural audio. It should be so easy. – user3169 May 29 '15 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.