1

Symtom is somewhat like this. BIOS is broken (?)

I can still enter UEFI Setup using efibootmgr -n on Linux, however press F2 according to what shown on the screen does nothing. Same for F12 (that is to select Boot Menu)

I'm planning to reinstall Windows, I can still using efibootmgr again but I'm afraid that it's one way trip, if the installation broken, there is no way to select a proper boot loader again.

Thanks in advance.

  • It's definitely the problem with firmware corruption. After reinstall Windows 8 and flash the firmware, it works now, both F2 and F12. – Quang Linh Le May 31 '15 at 0:02
  • 1
    You should write a detailed answer below if you've solved the issue. You can self-accept it too. – Karan May 31 '15 at 6:28
  • I realized you've fixed the problem, but be aware there's no standardization in EFI user interfaces -- F2 or F12 might work for you, but the keys to enter the firmware setup utility may be totally different on another computer. Specifying your make and model may be important for questions like this. As to the rest, boot loader information stored in NVRAM sometimes gets corrupted, leading to symptoms similar to what you've described. Clearing unused boot entries sometimes fixes the problem. This is basically a buggy firmware issue. – Rod Smith May 31 '15 at 16:06
  • Thanks for your comments, I'm thinking of writing a better explanation just in case someone else having the same situation... – Quang Linh Le May 31 '15 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.