3

I have done the following changes in my registry of windows 8.1

HKEY_CURRENT_USER\ Control Panel\Keyboard

set the value of InitialKeyboardIndicator is 2 but still the num pad is off while starting my laptop.

5

Answer/Tip:
Check your BIOS Setup for an option to have "NumLock" on at boot.

For registry hackers:
Run regedit, do a backup, search for "InitialKeyboardIndicators" and set the REG_SZ value of all instances to "2"
https://www.youtube.com/watch?v=Aw-isftXpXQ

  • Logically speaking though, shouldn't the OS option trump what you've selected in the BIOS? – Karan Jun 1 '15 at 10:29
  • Logic is one thing, OS and BIOS interaction another... ;-p - especially if the OS comes from MS. – Hannu Jun 1 '15 at 16:03
  • Well MS' OS works fine here and so does its NumLock setting. Hopefully the OP will confirm whether your suggestion worked for him or not. – Karan Jun 1 '15 at 19:33
  • There is no option of NumLock on BIOS menu. – K K Jun 2 '15 at 6:13
  • Then I can only recommend to use some other OS/Hardware. Fake (as in non-functional) and missing user preference settings are a no-no IMHO. – Hannu Jun 2 '15 at 17:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.