3

The Toshiba Satellite Click Mini is a special computer, it doesn't have any CD/DVD drive and the BIOS is special and very limited, it looks like this:

Boot menu presented

When I select "Enter Setup" I have a menu like this:

Enter setup menu

What I've done :

  1. I tried to remove a Linux Debian 8 "Jessie" installation by using EasyBCD 2.2 : in "BCD Management Options", "Re-create/repair boot files" (I've followed a video tutorial : http://youtube.com/watch?v=heO1n73Ua4Q)
  2. After that, I boot and go into the BIOS (by pressing Power button + Volume up), I disable the "Secure Boot" option in the Boot Menu (see the second image).
  3. I tried to boot on my USB stick with Ubuntu on it (also tried with a Windows repair disk image), but it doesn't work and it tries boots to Windows 8 everytime and the famous message pops up even if I choose my USB Stick from the Boot Menu (I can always boot to Windows 8 by reactivating the Secure Boot, it just prevents me to boot on another OS and that's pretty annoying) :

    error: no such partition Entering rescue mode... grub rescue> _

  4. So I searched on how to resolve this and people are telling that you need to enter these commands on grub rescue screen : ls and set, so I tried and this appear :

    grub rescue> ls (hd0) (hd1) (hd1,gpt4) (hd1,gpt3) (hd1,gpt2) (hd1,gpt1) (hd2) (hd3)

    grub rescue> set cmdpath=(hd1,gpt1)/EFI/debian prefix=(hd1,gpt5)/boot/grub root=hd1,gpt5

  5. In Windows 8 from the settings menu, I've turned off fast start-up and then I go in Advanced setup in PC settings menu/Troubleshoot/Advanced options/Command Prompt and entered the commands :

    bootrec.exe /FixMbr bootrec.exe /FixBoot exit

I searched everywhere on internet and didn't solve my problem, I think the Toshiba Satellite Click Mini laptop is a special case as the BIOS menu is very limited.

Thanks in advance for you answers !

  • English flawless as far as I can tell. Also, you did a very good job of writing this. – Griffin May 31 '15 at 16:44
  • ClickMini have only EFI mode boot. It does not know about MBR. Follow EFI related info in order to restore windows efi boot partition... – George Bungarzescu Feb 6 '17 at 17:18
  • Funny how the firmware itself uses the term BIOS. – jiggunjer Feb 7 '17 at 6:10
1

The problem is that tutorial was for a virtual machine that probably used a BIOS/MBR configuration, your laptop probably has a UEFI/GPT configuration. Apparently EasyBCD doesn't support UEFI 100%. The net result is that you didn't remove GRUB from your EFI partition, evident by the lines cmdpath=(hd1,gpt1)/EFI/debian prefix=(hd1,gpt5)/boot/grub

To fix this boot into a Windows recovery environment (secure boot setting shouldn't matter) and reset your efi.

To summarize that repair link, in the repair menu do:

  • bootrec /RebuildBcd
  • bootrec /fixMbr
  • bootrec /fixboot
  • bootsect /nt60 SYS
  • bootsect /nt60 ALL
  • Exit

You could probably also fix this from within Windows 8 too I suppose, or even using a linux livecd. If you have trouble booting into recovery, update your question. Perhaps you could include your partition information too. But normally a recovery disk can handle the job.


Update: Sorry just noticed this question is rather old.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.