1

I have a Linksys E900 router and I also upgraded my internet to a 100Mbps connection from 30Mbps but when I'm on WiFi I'm getting a maximum speed of 37Mbps just 4-5 feet away from the router. I have another PC that is wired to the router and the average speeds I'm receiving on that is 50Mbps. I've messed around with the wireless settings changing channels etc but it hasn't made a huge difference to the WiFi speeds. I plugged in my laptop directly to the ethernet cable provided by my ISP without the router, just to verify if the ISP messed up somehow and speedtest shows 98.2Mbps. What could be the issue?

Also I'm on wireless-n only and 2.4Ghz band and the channel width is set to 20Mhz or 40Mhz. Any help would be appreciated.

5
  • In order to pass the 54 Mbs limit, you must have both a router and a pc which are at least compatible with 802.11n, or 802.11ac better still. You should check both your pc, and your router to check this. 37 Mbs sounds exactly like a 802.11g connection, the previous (and weaker) standard. Commented Jun 2, 2015 at 7:00
  • Thanks for replying. My router does support the 802.11n standard and my PC and laptop I know for a fact do too. I've also set the router to wireless-n not g. Commented Jun 2, 2015 at 7:09
  • Did you search for any nearby interference? Things like other wifis (due to neighbors) on the same channel, microwave oven, cordless phone,... Commented Jun 2, 2015 at 7:14
  • I've removed cordless phones and anything that would cause interference a while ago and like I've changed channels too, still no go. Would switching to a 5 GHz supported router help? Commented Jun 2, 2015 at 7:27
  • What would really help is to run, in a Linux machine, the command iwlist scan . This would tell you the supported data rates (there are some surprises there, despite claims to 300Mbs rates), signal level (in dB), and quality, an index which does take into account interference. Switching to 5GHz is a shot in the dark: it might work, but then...it might not. Commented Jun 2, 2015 at 7:55

1 Answer 1

0

the e900 is 300mbps capable, I would suggest maybe you have an old wireless G card in the PC. Also try changing the wireless channel. If you are using a channel that is the same channel as other networks then this can cause your speeds to decrease.

1
  • I'm using my laptop to check the WiFi speeds from a couple feet away that has a wireless n enabled. I'm using a Toshiba Portege Z930 that is wireless n capable. I've also tried changing channels and optimized using inSSIDer. Commented Jun 2, 2015 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .