1

I can't successfully perform a complete scan using Windows update on my system. The scan is running endlessly, no errors and no timeout.

I have used the Microsoft repair tool WindowsUpdateDiagnostic.diagcab three times and every time it repairs the two following points:

  • Missing or corrupted registration service
  • Last updates installation problems

I'm not sure repairing is really effective because it detects the same errors each time.

I try the updates with a powershell script, but it seems to run endlessly too. Finally I stop it manually without any message from it.

Here is my windows update log:

2015-06-02  10:48:00:597     932    7b0 Misc    ===========  Logging initialized (build: 7.9.9600.16422, tz: +0200)  ===========
2015-06-02  10:48:00:597     932    7b0 Misc      = Process: C:\Windows\system32\svchost.exe
2015-06-02  10:48:00:597     932    7b0 Misc      = Module: c:\windows\system32\wuaueng.dll
2015-06-02  10:48:00:597     932    7b0 Service *************
2015-06-02  10:48:00:597     932    7b0 Service ** START **  Service: Service startup
2015-06-02  10:48:00:597     932    7b0 Service *********
2015-06-02  10:48:02:602     932    7b0 Agent     * WU client version 7.9.9600.16422
2015-06-02  10:48:02:602     932    7b0 Agent     * Base directory: C:\Windows\SoftwareDistribution
2015-06-02  10:48:02:602     932    7b0 Agent     * Access type: No proxy
2015-06-02  10:48:02:602     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 2.
2015-06-02  10:48:02:602     932    7b0 Service UpdateNetworkState Ipv4, cNetworkInterfaces = 2.
2015-06-02  10:48:02:602     932    7b0 Agent     * Network state: Connected
2015-06-02  10:48:02:633     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 2.
2015-06-02  10:48:02:633     932    7b0 Service UpdateNetworkState Ipv4, cNetworkInterfaces = 2.
2015-06-02  10:48:04:118     932    7b0 Agent   ***********  Agent: Initializing global settings cache  ***********
2015-06-02  10:48:04:118     932    7b0 Agent     * Endpoint Provider: 00000000-0000-0000-0000-000000000000
2015-06-02  10:48:04:118     932    7b0 Agent     * WSUS server: <NULL>
2015-06-02  10:48:04:118     932    7b0 Agent     * WSUS status server: <NULL>
2015-06-02  10:48:04:118     932    7b0 Agent     * Target group: (Unassigned Computers)
2015-06-02  10:48:04:118     932    7b0 Agent     * Windows Update access disabled: No
2015-06-02  10:48:04:165     932    7b0 WuTask  WuTaskManager delay initialize completed successfully..
2015-06-02  10:48:04:633     932    7b0 Report  WARNING: Failed to initialize event uploader for new server {9482F4B4-E343-43B6-B170-9A65BC822C77} with hr = 8024043d.
2015-06-02  10:48:04:633     932    7b0 Report  CWERReporter::Init succeeded
2015-06-02  10:48:04:649     932    7b0 Agent   ***********  Agent: Initializing Windows Update Agent  ***********
2015-06-02  10:48:04:649     932    7b0 DnldMgr Download manager restoring 0 downloads
2015-06-02  10:48:04:649     932    7b0 AU  ###########  AU: Initializing Automatic Updates  ###########
2015-06-02  10:48:04:649     932    7b0 AU  Additional Service {117CAB2D-82B1-4B5A-A08C-4D62DBEE7782} with Approval type {Scheduled} added to AU services list
2015-06-02  10:48:04:649     932    7b0 AU  AIR Mode is disabled
2015-06-02  10:48:04:649     932    7b0 AU    # Approval type: Scheduled (User preference)
2015-06-02  10:48:04:649     932    7b0 AU    # Auto-install minor updates: Yes (User preference)
2015-06-02  10:48:04:665     932    7b0 AU    # ServiceTypeDefault: Service 117CAB2D-82B1-4B5A-A08C-4D62DBEE7782 Approval type: (Scheduled)
2015-06-02  10:48:04:665     932    7b0 AU    # Will interact with non-admins (Non-admins are elevated (User preference))
2015-06-02  10:48:04:665     932    7b0 AU  WARNING: Failed to get Wu Exemption info from NLM, assuming not exempt, error = 0x80070032
2015-06-02  10:48:04:680     932    7b0 AU  AU finished delayed initialization
2015-06-02  10:48:04:680     932    7b0 AU  OOBE is in progress, so cannot perform Accelerated Install
2015-06-02  10:48:05:227     932    bec DnldMgr Asking handlers to reconcile their sandboxes
2015-06-02  10:48:05:727     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 3.
2015-06-02  10:48:06:775     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 4.
2015-06-02  10:48:09:197     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 3.
2015-06-02  10:48:09:275     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 4.
2015-06-02  10:48:26:995     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 3.
2015-06-02  10:48:26:995     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 2.
2015-06-02  10:48:27:136     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 3.
2015-06-02  10:48:27:277     932    7b0 Service UpdateNetworkState Ipv6, cNetworkInterfaces = 4.
2015-06-02  10:50:48:108     932    50c IdleTmr Incremented idle timer priority operation counter to 1
2015-06-02  10:50:55:328     932    974 AU  Triggering AU detection through DetectNow API
2015-06-02  10:50:55:328     932    974 AU  Additional Service {117CAB2D-82B1-4B5A-A08C-4D62DBEE7782} with Approval type {Scheduled} added to AU services list
2015-06-02  10:50:55:328     932    974 AU  Triggering Online detection (interactive)
2015-06-02  10:50:55:344     932    7b0 AU  Windows OOBE is still in progress. AU deferring detection
2015-06-02  10:50:55:344     932    7b0 AU  WARNING: BeginDetection failed, hr:0x8024a008
2015-06-02  10:50:55:344     932    7b0 AU  All AU searches complete.
2015-06-02  10:50:55:344     932    7b0 AU    # WARNING: Failed to find updates with error code 8024a008
2015-06-02  10:50:55:344     932    7b0 AU  AU setting next detection timeout to 2015-06-02 09:20:55
2015-06-02  10:50:55:359     932    7b0 AU  OOBE is in progress, so cannot perform Accelerated Install
2015-06-02  11:01:18:339     932    7b0 AU  ###########  AU: Uninitializing Automatic Updates  ###########
2015-06-02  11:01:18:340     932    7b0 WuTask  Uninit WU Task Manager
2015-06-02  11:01:18:478     932    7b0 Agent   Sending shutdown notification to client
2015-06-02  11:01:18:479    2456    16cc    Misc    ===========  Logging initialized (build: 7.9.9600.16384, tz: +0200)  ===========
2015-06-02  11:01:18:479    2456    16cc    Misc      = Process: C:\Windows\SysWOW64\sdiagnhost.exe
2015-06-02  11:01:18:479    2456    16cc    Misc      = Module: C:\Windows\SYSTEM32\wuapi.dll
2015-06-02  11:01:18:479    2456    16cc    COMAPI  WARNING: Received service shutdown/self-update notification.
2015-06-02  11:01:18:707     932    7b0 Service *********
2015-06-02  11:01:18:708     932    7b0 Service **  END  **  Service: Service exit [Exit code = 0x240001]
2015-06-02  11:01:18:708     932    7b0 Service *************
2015-06-02  11:01:19:709     932    78c Service *************
2015-06-02  11:01:19:709     932    78c Service ** START **  Service: Service startup
2015-06-02  11:01:19:709     932    78c Service *********
2015-06-02  11:01:19:719     932    78c Agent     * WU client version 7.9.9600.16422
2015-06-02  11:01:19:720     932    78c Agent     * Base directory: C:\Windows\SoftwareDistribution
2015-06-02  11:01:19:720     932    78c Agent     * Access type: No proxy
2015-06-02  11:01:19:720     932    78c Service UpdateNetworkState Ipv6, cNetworkInterfaces = 4.
2015-06-02  11:01:19:720     932    78c Service UpdateNetworkState Ipv4, cNetworkInterfaces = 2.
2015-06-02  11:01:19:720     932    78c Agent     * Network state: Connected
2015-06-02  11:01:19:726     932    78c Service UpdateNetworkState Ipv6, cNetworkInterfaces = 4.
2015-06-02  11:01:19:726     932    78c Service UpdateNetworkState Ipv4, cNetworkInterfaces = 2.
2015-06-02  11:01:19:753     932    7a4 Agent   ***********  Agent: Initializing global settings cache  ***********
2015-06-02  11:01:19:753     932    7a4 Agent     * Endpoint Provider: 00000000-0000-0000-0000-000000000000
2015-06-02  11:01:19:753     932    7a4 Agent     * WSUS server: <NULL>
2015-06-02  11:01:19:753     932    7a4 Agent     * WSUS status server: <NULL>
2015-06-02  11:01:19:753     932    7a4 Agent     * Target group: (Unassigned Computers)
2015-06-02  11:01:19:753     932    7a4 Agent     * Windows Update access disabled: No
2015-06-02  11:01:19:762     932    7a4 WuTask  WuTaskManager delay initialize completed successfully..
2015-06-02  11:01:19:766     932    7a4 Report  WARNING: Failed to initialize event uploader for new server {9482F4B4-E343-43B6-B170-9A65BC822C77} with hr = 8024043d.
2015-06-02  11:01:19:766     932    7a4 Report  CWERReporter::Init succeeded
2015-06-02  11:01:19:766     932    7a4 Agent   ***********  Agent: Initializing Windows Update Agent  ***********
2015-06-02  11:01:19:766     932    7a4 DnldMgr Download manager restoring 0 downloads
2015-06-02  11:01:19:767     932    7a4 AU  ###########  AU: Initializing Automatic Updates  ###########
2015-06-02  11:01:19:767     932    81c DnldMgr Asking handlers to reconcile their sandboxes
2015-06-02  11:01:19:767     932    7a4 AU  Additional Service {117CAB2D-82B1-4B5A-A08C-4D62DBEE7782} with Approval type {Scheduled} added to AU services list
2015-06-02  11:01:19:804     932    7a4 AU  AIR Mode is disabled
2015-06-02  11:01:19:804     932    7a4 AU    # Approval type: Scheduled (User preference)
2015-06-02  11:01:19:804     932    7a4 AU    # Auto-install minor updates: Yes (User preference)
2015-06-02  11:01:19:804     932    7a4 AU    # ServiceTypeDefault: Service 117CAB2D-82B1-4B5A-A08C-4D62DBEE7782 Approval type: (Scheduled)
2015-06-02  11:01:19:804     932    7a4 AU    # Will interact with non-admins (Non-admins are elevated (User preference))
2015-06-02  11:01:19:814     932    7a4 AU  WARNING: Failed to get Wu Exemption info from NLM, assuming not exempt, error = 0x80070032
2015-06-02  11:01:19:833     932    7a4 AU  AU finished delayed initialization
2015-06-02  11:01:19:834     932    7a4 AU  OOBE is in progress, so cannot perform Accelerated Install
2015-06-02  11:01:19:852     932    7a4 IdleTmr Incremented idle timer priority operation counter to 1

Can I fix this without having to restore my Windows installation?

  • Try this. – Karan Jun 2 '15 at 9:34
  • I have run the four command lines, all the opérations are completed successfully but my problem persists. – tyd01 Jun 2 '15 at 10:12
  • Finally, if the PowerShell script Get-WUInstall run for a long time, it succeed to install a lot of updates (~150). – tyd01 Jun 3 '15 at 10:35
1

It appears you are trying to run Windows updates in Audit mode or the OOBE has not completed, which is why it fails.

I found the following in your log

Windows OOBE is still in progress. AU deferring detection.

WARNING: Failed to find updates with error code 8024a008

OOBE is in progress, so cannot perform Accelerated Install.

.

"the OS has not completed OOBE"

Source

Some possibilities on repairing this issue in this thread, since we do not know why your PC is in audit mode the solution could be one of many.

  • Thank you, Moab. You seems to be right, the problem is my computer is in OOBE mode. Now I'm looking for fix it... – tyd01 Jun 3 '15 at 10:36
0

I come back to give you the way I have solve my OOBE problem :

1 ) When I tried to use the sysprep utility into my console, the command wasn't recognized but I succeed to use it directly from it's folder "c:\Windows\System32\Sysprep\Sysprep.exe \OOBE \reboot".

2 ) On reboot, my computer run the OOBE configuration (I create a temporary local user account to complete it) and finally block on the last step with the finalisation screen.

3 ) When the computer has been blocked on the finalisation script I have to use the "Ctrl + F10" command shortcut to access a terminal.

4 ) Type the "tasklist" command to list all the process running with there PID. There must be 2 cmd.exe process, the one about the current used terminal and the second one used by OOBE process. Note the PID (4 digits number) of this 2 cmd.exe processes ( PID1 and PID2) and type this command "taskkill \PID PID1 \PID PID2" replacing PID1 and PID2 by the real values. The OOBE must terminate and the login screen must appears.

5 ) At this point everything would be fixed, check windows updates process and log, if it's ok you can delete the temporary local account.

PS : There was some other problems on my computers, I was not looking for fixing it because it was not blocking or disturbing. I was not able to custom my account avatar or to custom the picture on the login screen. This problems have been solved with OOBE fix too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.