4

thank you for reading my post!

I am running Windows 8.1 in Bootcamp on my Macbook. For over a year I didn't have any trouble with it. Yesterday, the Windows partition failed to boot and I get a blue screen error since. It says 'Inaccessible boot device'.

First, I tried to start in safe mode, but still got the blue screen. I was looking for a solution online and came across some posts where people had similar problems.

They recommended to run the following commands in terminal: bootrec /rebuildbcd bootrec /fixboot chkdsk C: /f /r /x

But none of them helped to boot the Windows partition.

In OS X, the Windows partition is still showing up using Disk Utility as well as in the Finder.

However, the Bootcamp partition is listed under Devices and I cannot access any files/folder as they seem to be empty.

http://i.stack.imgur.com/BV6fK.png

Any ideas how to fix this? Would highly appreciate any help!


Update: I mounted the Windows EFI boot loader files and it looks like I did perform an EFI mode installation of Windows. bootmgfw.efi is located in Windows/Boot/ as well as boot.stl, bootmgr.efi, memtest.efi and BCD and some language specific folders. As far as I remember, I installed it as follows: I created two partitions using Boot Camp Assistent on the Mac and created a Windows installation USB drive from a Windows 8 ISO file. However, when installing Windows, it wanted me to partition the Bootcamp partition and that's how I got these two other partitions. I'll attach a screenshot of Disk Utility on the bottom.

I still don't get what went wrong! After closing the Macbook (when using Windows) and trying to re-open it a few minutes later, I couldn't get Windows to wake-up, so I had to long-pres the power button. Ever since, I get the blue screen error.

Disk Utility

  • If you recieve a blue screen it likely means a .dmp file is being created. Can you provide us the .dmp file that is being created upon encoutering BSOD? By the looks of it, it looks like your windows partition ran chkdsk and recovered corrupted files, if thats the case its also likely you have corrupted system files. If you have corrupted system files your options are extremely limited. This cannot be solved without a recovery disk – Ramhound Jun 2 '15 at 14:47
  • Thank you for your help. I indeed ran chkdsk, because that's what people recommended somewhere else. I hope that it didn't corrupt the OS. Where can I find the .dmp file? – user3260254 Jun 2 '15 at 15:28
  • Also: I created a USB drive from a Windows 8.1 ISO, but does it include recovery tools? – user3260254 Jun 2 '15 at 15:43
  • Update: I was wrong, I am still able to access all files and folders on the Bootcamp partition, so there is probably a problem with allocating the correct partition when booting the system. – user3260254 Jun 2 '15 at 18:41
0

Did you do any software installation, filesystem maintenance, or partition adjustments just prior to the problem occurring? It could be that your installation relies on a hybrid MBR (as do all Boot Camp installations), and that your hybrid MBR has become damaged or replaced with a standard GPT protective MBR. If so, the solution is to re-build the correct hybrid MBR -- but there are risks to doing this if you've adjusted your partitions recently. In particular, if you've used Windows tools to resize partitions, your GPT and MBR data will be dangerously out of sync, and recovering a consistent and correct set of partitions will require careful attention to detail. If the hybrid MBR has been replaced with a protective MBR or damaged in a less dangerous way, re-creating it with gdisk, gptsync, or some other tool should be relatively straightforward.

You can check the current state of the disk with gdisk:

$ sudo gdisk /dev/disk0
GPT fdisk (gdisk) version 1.0.0

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help):

This example shows a GPT disk (GPT: present) with a standard protective MBR (MBR: protective). A hybrid MBR disk will show MBR: hybrid. You can type p to show the (GPT) partitions, which you can review as a sanity check. Then, use v to check for GPT/MBR consistency (and other partition table problems):

Command (? for help): v

No problems found. 990 free sectors (495.0 KiB) available in 1
segments, the largest of which is 990 (495.0 KiB) in size.

Your details will differ, of course. If you uncover problems, edit your question to include the details and add a comment to my answer so I notice your reply.

A caveat: Some people install Windows 8 and later on Macs in EFI mode rather than using Boot Camp. You specified the latter, but if that detail was in error, you definitely do not want to add a hybrid MBR to your disk, since it will make matters worse.


EDIT:

You could have pasted your output into your original question by editing it. Adding four spaces to the start of each line will preserve formatting, helping legibility.

Before you try to adjust your hybrid MBR, I recommend looking for Windows EFI boot files. It could be that you've unknowingly installed Windows in EFI mode, in which case adjusting your hybrid MBR will be a waste of time that you'll have to undo later. You can check for Windows EFI boot files by mounting your ESP in OS X:

mkdir /Volumes/ESP
sudo mount -t msdos /dev/disk0s1 /Volumes/ESP

The Windows EFI boot loader files will normally be in /Volumes/ESP/EFI/Microsoft/Boot, given the /Volumes/ESP mount point I specified. If you find files there (bootmgfw.efi is the main file, but there are a number of support files), don't try adjusting your hybrid MBR; instead, investigate possible EFI boot troubles for Windows on Macs.

In fact, your partition list makes me suspicious that you did perform an EFI-mode installation of Windows, although I'm not 100% positive of that.

If you don't see any Windows boot files on your ESP, you can create a hybrid MBR by following the instructions on the gdisk hybrid MBR page. You'll need to decide which partitions to include in the hybrid MBR. Your Windows boot partition is the most critical (your partition #5), but it looks like you've got two other Microsoft partitions (#4 and #6).

| improve this answer | |
  • Thank you for your reply, Rod! I did not adjust the partition, filesystem or any other adjustments. However, a Windows update might have been installed. By looking through the files in the Bootcamp partition, I noticed that the last modified files are OS related. The file, that got last modified, is probably bootstat.dat in the Windows folder. – user3260254 Jun 2 '15 at 23:17
  • If the MBR should be hybrid by default - when using Bootcamp - then it may be an MBR problem, as you said. Using gdisk, it got the following results: – user3260254 Jun 2 '15 at 23:22
  • $ sudo gdisk /dev/disk0 GPT fdisk (gdisk) version 1.0.0 Warning: Devices opened with shared lock will not have their partition table automatically reloaded! Partition table scan: MBR: protective BSD: not present APM: not present GPT: present Found valid GPT with protective MBR; using GPT. – user3260254 Jun 2 '15 at 23:32
  • Command (? for help): p Disk /dev/disk0: 236978176 sectors, 113.0 GiB Logical sector size: 512 bytes Disk identifier (GUID): C3B277A4-03B5-4ECE-8781-C13BA7444A11 Partition table holds up to 128 entries First usable sector is 34, last usable sector is 236978142 Partitions will be aligned on 8-sector boundaries Total free space is 2261 sectors (1.1 MiB) – user3260254 Jun 2 '15 at 23:35
  • Number Start (sector) End (sector) Size Code Name 1 40 409639 200.0 MiB EF00 EFI System Partition 2 409640 78534639 37.3 GiB AF00 Apple_HFS_Untitled_2 3 78534640 79804175 619.9 MiB AB00 Recovery HD 4 79804416 80066559 128.0 MiB 0C01 Microsoft reserved ... 5 80066560 236259327 74.5 GiB 0700 Basic data partition 6 236259328 236976127 350.0 MiB 2700 – user3260254 Jun 2 '15 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.