1

I have to enter a website that has an invalid certificate and I can't because Chrome won't let me (to protect me, how hilarious!).

I don't want or need to be protected, so I just want to completely disable the SSL feature to continue working without wasting more time.

Any tips?

4
  • Add the certificate to the user's certificate store and it should solve your problem. If you disable SSL you wouldn't be able to connect to the website at all – Ramhound Jun 2 '15 at 19:17
  • Can you tell me how to do that? – octohedron Jun 2 '15 at 19:17
  • What install self-signed certificates? what step in the process are you stuck on? – Ramhound Jun 2 '15 at 19:38
  • i dont know where to get the certificate or where to install it – octohedron Jun 2 '15 at 19:40
1

In chrome, if you get an invalid certificate warning, you can still continue if you choose to. When you get the message "Your connection is not private", click on "Advanced". Then "Proceed to .... (unsafe)".

Note you cannot disable "the ssl feature". SSL is one of the most important security features the web has to offer. Whether or not to use SSL is determined by the site, not by you or your browser. If the site you are going to has an invalid SSL cert, it's possible that you are not actually on the site you think you are on, so you should be careful when entering in passwords or personal information. The browser is trying to protect you by warning you that the SSL certificate is not verified. But all browsers let you continue anyway if you want to.

This may help too: Continuing beyond Chrome SSL Warnings

5
  • for some reason i can't continue in FF or chrome in ubuntu – octohedron Jun 2 '15 at 22:33
  • What does the error message say regarding the cert? I added a link which may help. – TTT Jun 2 '15 at 22:45
  • danger doesnt work, its the same error it gives to everyone i just cant find the proceed anyways option anywhere – octohedron Jun 2 '15 at 22:57
  • This is only true is the site isn't using HSTS. If the site has sent the HSTS header, then you CAN NOT proceed. That's the point of HSTS. – ssnobody Jun 3 '15 at 1:36
  • well, i will have to sell my computer then. – octohedron Jun 3 '15 at 7:11
1

Sadly Google does not give the user an easy way to add a Certificate to the list of trusted certificates. To get rid of the message you should add the certificate to your OS's trusted certificates. How this can be achieved is however system dependent.

This is the steps that should work for Ubuntu (Copied from this question, more info there):

  1. Click the lock icon with an x
  2. Choose Certificate Information
  3. Go to details tab
  4. Click on Export... (save as a file)
  5. Now, the following command will add the certificate (where YOUR_FILE is your exported file): certutil -d sql:$HOME/.pki/nssdb -A -t "P,," -n YOUR_FILE -i YOUR_FILE

To list all your certificates, run the following command: certutil -d sql:$HOME/.pki/nssdb -L

If nothing helps you can always just choose to ignore the certificate issue. Notice howerver that this means you will loose all protection from man-in-the-middle-attacks! If you still decide to solve your problem this way, having to do two extra clicks to proceed to the website every time can get quite annoying. To get around this in Chrome you can set a time in
chrome://flags/#remember-cert-error-decisions, leadings to the Error being shown only once every three months.

Happy Hacking,
Nuwanda

4
  • I added the ubuntu tag when i asked my question. I dont care about the attacks and i cannot make any decisions so its pretty useless to remember them. – octohedron Jun 3 '15 at 7:09
  • I am sorry, i didn't notice that tag, I edited my answer. – Nuwanda Jun 4 '15 at 15:06
  • Sadly chrome://flags/#remember-cert-error-decisions was removed see here link I have to administer 1000 routes and the is slowing me down. – Eugene van der Merwe Feb 28 '16 at 0:39
  • This is an old question, that has already been answered. It also has absolutely nothing to do with routes. Please post a new question, making sure to describe your problem as accurate as you can. In addition to that please be aware, that chrome://flags/#remember-cert-error-decisions is not the solution for this question. It is a workaround and should never be used for extended periods of time or in a production environment. – Nuwanda Feb 29 '16 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.