0

After installing Intel eXtensible Host Controller Driver (http://www.dell.com/support/home/uk/en/ukbsdt1/Drivers/DriversDetails?driverId=KG9P5). USB ports (both 2.0 and 3.0) stopped working for USB mass storage. Device is properly recognized when connected but driver installation fails - it's both for portable hdd's and flash sticks. All I have in Device manager is external drive with yellow icon and Error 10 in description. All those devices work connected to different computer. BUT: USB mouse works (Logitech G300). Also wireless dongle for Logitech trackball is fine. Cooling pad works as well, so there is power. And I know it's that driver because my external WD HDD stopped working exactly when i rebooted after installing that crap. Drives are recognized by Bios and can boot from them. It's only when in Windows...

Uninstalling driver doesn't change USB state, plus i'm left with unrecognizable device in Manager.

Tried reinstalling, but no joy. Tried reinstalling chipset driver, but seems to not do a thing. Can't find uninstall for chipset. Tried rollback, but it seems like those installations did not create restore points, and rollback to point before all those issues failed. Rollback from f8 (last known good config) during boot also did not help.

Does anyone have any idea where to look for original drivers for USB? It will be 2.0 for all ports, i know, but better to have that than nothing. And how to install them? I'm not keen to do another reinstall especially when there will be problem with backup...

Also, does anyone know if there is a way to have 3.0 ports working as 3.0 after that?

My machine is Dell Inspiron 15R SE (7520) with i5-3320M, 256GB 850 EVO and 8GB RAM. Installed is win 7 Pro x64 (downgraded from Win8) and latest BIOS.

EDIT: Correction - system has 4xUSB3.0, not 2xUSB2.0+2xUSB3.0. Kinda explains failure on all ports. And I never bothered to look closer...

  • Disconnect all usb devices, then In device manager "Uninstall" the USB EHCI, the eXtensible host controller and 3.0 root hub, then restart the pc. – Moab Jun 2 '15 at 23:22
  • Already did that too... First thing to do, so basic I didn't think to include in description. But comment not wasted - is there an order to that uninstalling? Because 3.0 root hub disappears with uninstalling first EHCI... – AcePL Jun 3 '15 at 8:21
  • No, as long as they all get removed. – Moab Jun 3 '15 at 13:10
  • So tried several methods (uninstall via Add/Remove what can be done that way), with deleting driver, without deleting driver. No effect. HDD has an error message: "Device cannot be started. Code 10". – AcePL Jun 3 '15 at 13:48
  • All I can suggest is to try a Windows system restore point, pick a date before usb was damaged. – Moab Jun 3 '15 at 14:46
0

It looks like the culprit is the installer on Dell website (1.0.7.248). After uninstalling the whole package and updating driver for device in Device manager I managed to get them to work as 2.0. I invested time in reinstalling windows anyway and it did not help.

But...

I downloaded newer versions straight from Intel site and - while it's still effectively only USB2.0 - the ports work after installing the software (ver. 1.0.10.255)

But this created another issue - after installing it Windows Explorer started crashing and restarting every minute or two. Looks like I need to scrub system from all the Dell drivers I can.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.