0

I have a hard drive that became corrupted during a Windows Update. It's possible that the drive became full and the update aborted in the middle, but I'm unsure.

Whatever the cause, the ntfs has become corrupted and the computer won't boot. However, I can put the drive in an external enclosure and mount it read-only on another system. I cannot mount it read/write. Right now I'm assuming this is why the computer won't boot.

I have tried to repair the drive using ntfsfix from a Linux machine. The command produces the following output:

ntfsfix /dev/sdb1
Mounting volume... The disk contains an unclean file system (0, 0).
FAILED
Attempting to correct errors... 
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK

Here the command hangs forever.

I get the same results when trying to ntfsfix the recovery partition (/dev/sdb1), which is definitely not full, and the system partition (/dev/sdb2), which might be full.

How can I get this drive working again?

  • 1
    Should be easy enough to determine if the hard drive is full or not. – Moab Jun 3 '15 at 2:05
  • Did you try booting from Windows Setup media and running chkdsk? – Karan Jun 3 '15 at 23:06
  • @Karan I was finally able to make a USB drive of the Windows 7 installation disk. However, when booting from it, no matter what option I choose, Windows boots, loads a bunch of drivers, and then puts me at a black screen with white cursor. The cursor moves around, but I can't do anything else. If I remove the hard drive and boot from the USB drive, then it finishes booting fine (but there's no hard drive to repair!) – drs Jun 4 '15 at 23:58
  • Ok, so at this point are you looking to recover data? If so try TestDisk, it might help. Otherwise see if GParted can wipe the disk so you can start afresh. – Karan Jun 5 '15 at 7:27
  • I'm getting same error. – Silvio Delgado Oct 9 '16 at 0:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.