I'm running an Asus Eee PC with Windows 7 Starter Edition. I have a Linksys print server set up already for my Windows Vista laptop.

When I open the setup wizard on the Eee PC, as soon as I click on "set up computer" I get a prompt:

The OS not support

There don't seem to be any Windows 7 drivers on Linksys' website. Any ideas how I can get it working?


You probably don't need any special drivers. That printer server supports standard IPP. Unplug power to your WPSM54G and connect the print server to your wired network. Power the WPSM54G back up.

Try opening a web browser and going to http://192.168.X.Y/ (substitute the IP address of your WPSM54G). You can configure the security using the embedded web site.

You should be able to define a netowrk printer using a URL like ipp://192.168.X.Y:631/ipp/P1

| improve this answer | |

Answer is here.


| improve this answer | |
  • could you translate some of this please? – user20285 Jan 16 '10 at 17:56

Try this: The post http://www.ehow.com/how_5396340_set-vista-vista-windows-linux.html helped me a lot, but all of it didn't quite work. This is what I did in addition. It was a bit of a process and probably could be done a simpler way but...

So with all the steps in the link followed then:

  • I went into my router and entered the print servers mac address (which you can get from the print servers browser page) into the DHCP reservations so the WPSM54G would definitely get the right IP address every time (you may be able to omit this step)
  • Then I connected the print server directly into my network with a cable. Turned on the printer, then turned on the print server, and then ran the SETUP PRINT SERVER wizard again (notice I said print server setup wizard not computer setup wizard). I gave it all the same settings but this time it detected the printer when setting up the server itself.
  • I still couldn't get the setup computer wizard to run, but the steps in the link above did the trick for that side of things.

Now it prints like a charm. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.