3

I removed the DVD optical drive and put a SSD in an optical drive caddy (similar to this: http://www.ebay.com/itm/2nd-Hard-Drive-Caddy-Adapter-for-Acer-Aspire-5750G-5755G-/280914405128). I have ubuntu installed on the SSD and it works without problem once it's started. The only issue I have is that the boot time of ubuntu seems long (for being on a SSD). It's around two minutes and I expected it to boot kinda instantaneously. I haven't installed a lot of crap since I mostly use ubuntu for school. Do you know what the problem might be? May the problem occur because the SATA port was intended for an optical DVD? Does anyone know anyone who has tried this setup (SSD in caddy) and have the same problem?

NOTE: I have two OS:s: 500gb HDD - Windows 7 60gb SSD (on caddy instead of DVD drive) - Ubuntu GNOME 15.04

Thanks! ^^

EDIT: My hdparm result is:

sudo hdparm -Tt /dev/sdb

/dev/sdb:
 Timing cached reads:   19112 MB in  2.00 seconds = 9564.39 MB/sec
 Timing buffered disk reads: 980 MB in  3.00 seconds = 326.37 MB/sec

And my service list is:

service --status-all
 [ + ]  acpid
 [ + ]  alsa-utils
 [ - ]  anacron
 [ + ]  apparmor
 [ + ]  apport
 [ + ]  avahi-daemon
 [ + ]  binfmt-support
 [ - ]  bluetooth
 [ - ]  bootchart
 [ - ]  bootmisc.sh
 [ - ]  brltty
 [ - ]  checkfs.sh
 [ - ]  checkroot-bootclean.sh
 [ - ]  checkroot.sh
 [ - ]  console-setup
 [ + ]  cron
 [ + ]  cups
 [ + ]  cups-browsed
 [ + ]  dbus
 [ + ]  dns-clean
 [ + ]  gdm
 [ + ]  grub-common
 [ - ]  hostname.sh
 [ - ]  hwclock.sh
 [ + ]  irqbalance
 [ + ]  kerneloops
 [ - ]  killprocs
 [ + ]  kmod
 [ - ]  lvm2
 [ - ]  mountall-bootclean.sh
 [ - ]  mountall.sh
 [ - ]  mountdevsubfs.sh
 [ - ]  mountkernfs.sh
 [ - ]  mountnfs-bootclean.sh
 [ - ]  mountnfs.sh
 [ + ]  network-manager
 [ + ]  networking
 [ + ]  ondemand
 [ - ]  pppd-dns
 [ + ]  procps
 [ + ]  rc.local
 [ + ]  resolvconf
 [ - ]  rsync
 [ + ]  rsyslog
 [ - ]  saned
 [ - ]  sendsigs
 [ - ]  spamassassin
 [ + ]  speech-dispatcher
 [ - ]  sudo
 [ - ]  thermald
 [ + ]  udev
 [ + ]  udev-finish
 [ + ]  ufw
 [ - ]  umountfs
 [ - ]  umountnfs.sh
 [ - ]  umountroot
 [ - ]  unattended-upgrades
 [ + ]  urandom
 [ - ]  uuidd
 [ + ]  whoopsie
 [ - ]  x11-common
  • where is the research?, did you benchmark your HDD ?, port your services list, do some more to get a good answer. – Francisco Tapia Jun 3 '15 at 13:13
  • Sorry, I added it now. I have updated my BIOS as well (but no change in boot time). – Jonas Markström Jun 3 '15 at 13:25
2

So I have solved the issue after spending many hours searching for the problem.

The problem was that the /etc/fstab file specified that there were TWO swap partitions (I only have one). So I removed the row specifying the swap partition that didn't exist and now the OS boots almost instantaneously. :)

I found the error by removing the "quiet splash" boot option. I could see during boot that it tried to contact the nonexisting partition for 1m 30sec.

Hope this helps someone! :)

| improve this answer | |
0

I had the same problem with long boot times until I disconnected my DVD writer. I then remembered that my motherboard had 2 sets of SATA connectors. I had both HDD's and the DVD writer on the same set. When I moved the DVD drive to the other set of SATA connections the problem disappeared. Maybe this will help other users searching on this subject. It would have saved me about 2 days of research!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.