1

So I had a dual boot, on separate drives, for Ubuntu 14.04 LTS and Windows 7 Pro (all 64bit). My Windows install had come first, and then Ubuntu. This was a year or so ago. The other day I felt it was time to reinstall Windows as it was a cluttered mess. That went smoothly. Upon rebooting however my grub menu was gone.

I thought "no biggie, boot-repair will fix it like always" however (all OSes are accessible when I bring up the boot menu with FF11) it reports it was successful but actually isn't. No grub and this is with recommended settings. So I went into Advance settings and clicked "Backup and Rename Windows EFI Files".

This worked in a way I didn't not expect. First it brought me the grub menu, good and all, but the entries were really odd. Ubuntu's entry worked flawlessly but none of the Windows' entries did. Whenever they would boot into Windows it would take two minutes (never had this happen before) and then all my USB ports would stop working as soon as the log in screen appeared. Nothing I do seems to fix it.

So the only way to get into Windows with USB ports working is to press F11 at boot, select "Windows P1 Manager" (there are several entries even in here) from the boot menu (not the grub menu!). This would boot in about 20-30 seconds and give me USB port control again. However it means no grub and no Ubuntu unless I press F11 each time and load Ubuntu that way.

I have no idea what to do. I have never encountered this problem before. I sure would appreciate any and all help!

migrated from unix.stackexchange.com Jun 3 '15 at 16:55

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

  • There are a lot of tutorials around (I would have to look one up). Microsoft's windows, does not want to work with another OS, therefore you must get Ubuntu to work with it. You need to re-install grub, the Windows installer will have written over it. You can do that using a live Ubuntu CD/USB. It may be possible to do with the Ubuntu install disk. Some installers allow you to skip to this, last, step. When grub is re-installed it will search for all OSs and add a menu item to the boot screen. – ctrl-alt-delor Jun 3 '15 at 18:24
  • I have tried reinstalling the grub through Boot-repair as well as manually by mounting to it and then sudo update-grub (and more ways). When it does it it adds the entries but there are multiple entries, some of which boot in without USB ports working at all for Windows. – Dorzalty Jun 4 '15 at 11:38
0

I had this issue before, the way I fixed it was using EasyBCD in windows to recreate the bootloader.

However, if you want to use GRUB then you will need to edit the configuration file so that the right partitions are set for your installation.

  • Okay I will try EasyBCD next! I can get the grub menu up but the Windows entries boot slow + with no USB port support/working. – Dorzalty Jun 4 '15 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.